Эта тема на forum.dklab.ru


Алекс Светкин: ошибки перед выполнением .php5 CGI
У меня уставновлен базовый набор от 2005-07-19. Решил поставить php5 как cgi версии 2005-07-19. .php5 скрипты вроде нормально запускаются, но перед каждым выполнением появляется диалоговое окно windows, что:
---------------------------
Warning
---------------------------
PHP Startup: јy·: Unable to initialize module
Module compiled with module API=20020429, debug=0, thread-safety=1
PHP compiled with module API=20041030, debug=0, thread-safety=1
These options need to match
---------------------------
ОК
---------------------------
Переставлял с нуля последнюю версию денвера, все так же (потом откатился на предыдущую).
Как можно заставить php5 работать без этих окошек? Еще на машине стояли ZendServer 4/5, но не думаю, что дело в них.
Алекс Светкин:
Вопрос исчерпан. Кто-то (zend studio?) прописал в реестр неправильный путь к php.ini.
peyote:
А можно подробнее, у меня такая же проблема, искал ключи в реестре ("php.ini") пути правельные, может я не то нашел...
Установил Base_2005-07-19_a1.3.31_p4.4.0_m4.1.8_pma2.6.1.exe
Затем Zend Server 5 на дэнвера
Затем Zend Studio 5
И всё работало прекрасно, пока не поставил PHP5_2005-07-19_5.0.4.exe

Стало кидать ту же ошибку:
---------------------------
Warning
---------------------------
PHP Startup: јy·: Unable to initialize module
Module compiled with module API=20020429, debug=0, thread-safety=1
PHP compiled with module API=20041030, debug=0, thread-safety=1
These options need to match
---------------------------
ОК
---------------------------
peyote:
Всё решилось, удалил этот ключ:

[HKEY_LOCAL_MACHINE\SOFTWARE\PHP]
"IniFilePath"="X:\\usr\\local\\php\\"

:)
Maus:
Интересно, зачем ЗендСтудио пишет что-то в реестр??

Перенесено из форума: Форум для начинающих :: Денвер.
Перенесено в форум: Полезные советы :: Денвер.

Эта тема на forum.dklab.ru