Эта тема на forum.dklab.ru


macsim: Как обновить PHP в Denwer до версии 5.2.6
Возможно ли обновить PHP Version 5.2.4 в Denwer, на версию PHP 5.2.6 Released и как?
Юрий Насретдинов:
Можно. Разворачивайте дистрибутив (zip) поверх, сохранив php.ini (если Вы там что-то меняли, конечно)
Александр Михалицын:
Перенесено из форума: Тестовый форум.
Перенесено в форум: Полезные советы :: Денвер.
user2012x:
А как обновить php в denver с php 4.4.4 с php до какого нибудь 5 - ого, чтобы больше ничего не трогать и базы не переносить и т.п.
php 4 наверно еще что - то нао поменять или как?
Как обновить используя дистрибутив с php.net (там версии поновее)
и из денвера с php 5? Это проще чем с php.net или нет?

И велика ли несовместимость между php 4.4 и php 5 разных версий?
Я слышал о ней и наблюдал её раз.
Скрипт работавший под php 4 не работал на хостинге с php 5.3 и о том что могут быть проблемы с совместимостью там было написано.
судя по вссему из - за функции ereg(), а может и что другое... не помню почему на неё подумал...
php 5.2 более совместим с php 4.4 чем 5.3 или как?

И что насчет версий php выше?
Maus:
php 5.2 более совместим с php 4.4 чем 5.3 или как?
скорее, наоборот.
Основное изменение 5.2 ->5.3 это пространства имён, имхо.

А как обновить php в denver с php 4.4.4 с php до какого нибудь 5 - ого, чтобы больше ничего не трогать и базы не переносить и т.п.
подозреваю, что не взлетит.
но кошерный путь немногим сложнее:
0) переименовать ярлыки на рабочем столе и в автозагрузке. Сделать бэкап всего виртуального диска (считайте меня перестраховщиком). Сделать дампы всех баз (каждую - в отдельный файл), кроме служебных(mysql, pma, information_schema). Остановить комплекс.
1) поставить отдельно Денвер с PHP5, режим запуска reserve. Запустить его, проверить на работоспособность. Поменять какие-то настройки (если нужно). Завести заново пользователей в mysql и базы. Импортировать базы из дампов.
2) Остановить новый комплекс.
3) из старого комплекса перекопировать папки виртуальных хостов.
4) Запустить новый комплекс, проверить, что всё работает.
artemida: Как правильно обновить версию php?
Прежде чем делать, я еще раз хочу узнать, как правильно обновить версию php?
Как я понимаю, нужно скачать дистрибутив новой версии php на http://windows.php.net/download/ (но, там много ссылок на скачивание, что именно нужно качать?),
затем распаковать в C:WebServes/usr/local/php5,
предварительно удалив все файлы, кроме php.ini?
Так?
-=Vovka=-:
Появилась проблема с утановкой PHP версии 5.6. Стоит последний Денвер-3.
Скачал с сайта http://windows.php.net/downloads/releases/php-5.6.5-nts-Win32-VC11-x86.zip архив, распаковал в каталог php5 Денвера, запускаю php.exe - выдает, что этот файл "Не является приложением Win32".

Как поступить?
vitalino87:
Я скачивал с нормального сайта, поэтому проблем с установкой у меня не было. Рекомендую всем выбирать нормальные источники!

Эта тема на forum.dklab.ru