Эта тема на forum.dklab.ru


Mihail Silin: localhost не грузится на Windows 7
Denwer 3 — Base_2010-03-18
Установился нормально. Диск создал нормально. Запустилось все как надо. Но в браузере не открывается, ни localhost, ни 127.0.0.1.

В чем может быть проблема?




Win 7 Pro x64 — брандмауэр отключен, DNS-клиент работает, ping как в инструкции (http://www.denwer.ru/base.html)
Dr. Web — запрет на редактирование файла hosts снят.
Outpost Firewall — не ругается.


hosts

127.0.0.1 www.localhost

127.0.0.1 www.subdomain.localhost
127.0.0.1 www.subdomain.test1.ru
127.0.0.1 www.Tools.localhost
127.0.0.1 subdomain.localhost
127.0.0.1 subdomain.test1.ru
127.0.0.1 Tools.localhost
127.0.0.1 www.test1.ru
127.0.0.2 custom-host
127.0.0.2 www.custom
127.0.0.1 localhost
127.0.0.1 test1.ru
127.0.0.2 custom

bæv:
Mihail Silin, Не грузится localhost


Перенесено из форума: Базовый пакет :: Денвер.
Перенесено в форум: Лень сходить в Поиск или почитать документацию.
Mihail Silin:
Win32DisableAcceptEx On — не помогает (в моем релизе он включен изначально)
netsh winsock reset — не помогает


Единственное, что вызывает сомнение — почему-то не работает команда telnet localhost 80
Mihail Silin:
А без TELNET сервера Денвер может работать?
Ivan1986:
он по жизни работал без telnet сервера,
а вот почему у вас в винде нету telnet клиента, который входит в стандартный комплект - это уже другой вопрос.
Mihail Silin:
Ivan1986, у меня Win 7. В ней, как и в Висте, telnet изначально не установлен. Это политика безопасности Микрософта.
Ivan1986:
тогда вам нужно проверять работу чем-то другим
либо браузером, либо чем-то еще, что в этой поделке оставили.

Пипец, с каких это пор телнет клиент стал опасным...
Mihail Silin:
Да включить-то его не проблема. У меня он работает, как и написано в инструкции по установке Денвера.
Mihail Silin:
Как оказалось, проблемы создавал фаервол. Достаточно сделать 127.0.0.1 доверенным узлом, и все начинает грузиться.
bæv:
Перенесено из форума: Лень сходить в Поиск или почитать документацию.
Перенесено в форум: Полезные советы :: Денвер.
bæv:
Ветка выделена в отдельную тему «спам»,
расположенную в форуме Мусоропровод (22 Декабря 2010, 20:51).
bæv:
Ветка выделена в отдельную тему «adobe dreamviewer и dating pro»,
расположенную в форуме Мусоропровод (09 Января 2011, 13:45).
e1f:
Отключи Microsoft IIS и будет тебе счастье.
Зайди в Удаление/добавление компонентов Windows найди там IIS и сними галочки :) Незабудь ребут.
bæv:
e1f, во-первых, http://forum.dklab.ru/about/todo/PravilaEtogoForuma-ProchitayteObyazatelno.html — на форуме принято обращение «на Вы».

Во-вторых, тредстартер проблему уже решил.
Alexchucky:
А как решили проблему у меня таже проблема второй день голову ломаю!?
master sporta:
telnet в виндовс 7 можно включить зайдя в программы компоненты/ включение или отключение компонентов виндовс
Match:
Outpost по умолчанию не считал 127.0.0.1 доверенным хостом? Ничего себе политика безопасности у файрволла!
spardax:
Отключи Microsoft IIS и будет тебе счастье.
Зайди в Удаление/добавление компонентов Windows найди там IIS и сними галочки :) Незабудь ребут.

У меня не выходит отключить Microsoft IIS, пишет "произошла ошибка. некоторые компоненты установить не удалось"
Что можете посоветовать?
bæv:

У меня не выходит отключить Microsoft IIS, пишет "произошла ошибка. некоторые компоненты установить не удалось"
Что можете посоветовать?

— обращаться в службу поддержки майкрософт.
toxig:
Коротко опишу свою проблему и ее решение (извиняюсь, если баян):

Локальные сайты недоступны, "Сервер не найден".
Windows полностью игнорирует содержимое Файла hosts ("C:\Windows\system32\drivers\etc\hosts")

Т.к. Denwer полностью завязан на файл hosts (перенаправление маршрутов на локальные сайты), без него Denwer работать не будет.
В итоге видим картину при попытке зайти на сайт видим сообщение: Сервер не найден.

Решение проблемы:

1. После запуска Denwer проверяем наличие маршрутов на IP 127.0.0.1 в файле hosts
Пример маршрутов:
127.0.0.1 localhost
127.0.0.1 www.subdomain.localhost
127.0.0.1 www.subdomain.test1.ru
127.0.0.1 subdomain.localhost
127.0.0.1 subdomain.test1.ru
127.0.0.1 www.localhost
127.0.0.1 www.test1.ru
127.0.0.2 custom-host
127.0.0.2 www.custom
127.0.0.1 test1.ru
127.0.0.2 custom

2. Проверяем наличие пути к hosts в реестре Windows:
Нажмите кнопку Пуск -> Выполнить -> вводим команду regedit
Найдите следующий раздел реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
Проверяем наличие параметра: Имя [DataBasePath] + Тип [REG_EXPAND_SZ] или [REG_SZ] + значение [%SystemRoot%\System32\drivers\etc]

3. Если установлен Skype, отключаем использование портов 80 и 443 в программе.
Skype -> Инструменты -> Настройки -> Дополнительно -> Соединение -> отключить опцию: "Использовать порты 80 и 443 в качестве входящих альтернативных"

4. Если п. 1, 2, 3 в порядке:
удаляем файл hosts и создаем файл заного (предварительно сохранив его содержимое)
ошибка связана с политикой прав в Windows (некорректный владелец файла)

В моем случае сайты загрузились после п.4 ;)
AlkatraZ:
Я тоже столкнулся с данной проблемой localhost и опишу подробнее...
---
Разумеется сама Windows 7 чистая, никаких левых прог, скайпов, файрволов (кроме родного) нет.
HOSTS тоже настроен нормально, в нем проблем нет.

Но тем не менее, разрабатываемые скрипты, установленные на локальном сервере, как то странно подтормаживали, причем иногда сильно (несколько секунд), иногда меньше, но все равно время генерации было странно большим. Более того, я заметил, что скорость доступа к localhost почему-то зависит от состояния связи с моим Интернет провайдером.

Желая разобраться в причине, я запустил профилировщик и с удивлением обнаружил. что 1 секунду съедает соединение с локальным сервером MySQL, хотя по идее, это должно происходить практически мгновенно. В параметрах соединения с MySQL было указано 'localhost', все в принципе работало, но возникал тормоз.
---
Далее, я начал разбираться в причине.
1) Если отключить сетевой адаптер (вынув шнур компьютерной сети), или просто отключить DSL модем, все начинает работать мгновенно и без тромозов.
2) Если в настройках соединения вместо 'localhost' указать '127.0.0.1', то опять все начинает работать мгновенно и без подтормаживаний.

Как результат, складывается впечатление, что Windows 7 почему то по-умолчанию маршрутизирует запрос на localhost через интернет провайдера, что по идее не должно быть. На Windows XP такой проблемы нет и она корректно отрабатывает localhost
Кто нибудь знает, как исправить, чтоб запрос на 'localhost' не лез в интернет, а сразу обращался на 127.0.0.1
Ковырять HOSTS не предлагайте, ибо там все правильно.
bogoiskatel:
У меня Денвер заработал с IIS когда после его запуска мы ввели в строке браузера не localhost a localhost/denwer - все заработало! Оттуда же и базу установил. И сайты работают нормально, Wordpress поставил без проблем.
Руслан001: Не работает Denwer на Windows 7
Здравствуйте. Хочу поделиться, как я устранил проблему с Denwer. Если у вас установлен Denwer и виртуальная машина VMware Workstation, то Apache входящий в состав Denwer может возмущаться, что 443 порт занят.
Чтобы VMware его не использовал заходим в панель управления виртуальной машины (закладка ПРАВКА), выбираем НАСТРОЙКИ, затем пункт ОБЩИЕ ВИРТУАЛЬНЫЕ МАШИНЫ. В нем назначаем порт отличный от 443 (я поставил 444). Если поле порта не активно, то сначала надо выключить сервер, нажав ОТКЛЮЧИТЬ ОБЩИЙ ДОСТУП.
После этого Denwer вновь работает.
Judge:
Чтобы VMware его не использовал заходим в панель управления виртуальной машины (закладка ПРАВКА), выбираем НАСТРОЙКИ, затем пункт ОБЩИЕ ВИРТУАЛЬНЫЕ МАШИНЫ. В нем назначаем порт отличный от 443 (я поставил 444). Если поле порта не активно, то сначала надо выключить сервер, нажав ОТКЛЮЧИТЬ ОБЩИЙ ДОСТУП. После этого Denwer вновь работает.

Аналогичная ситуация, перепробывал всё что только можно было, а оказалось что VMware сидел на 443 порту! Сменил и всё заработало!
Jenssen Arcana:
Конфликт Denwer и VMware (не запускается localhost)

Как решить проблему с запуском локальных сайтов:

1. Открываем VMware
2. Идем в "Edit => Preferences... => Shared VMs"
3. Жмем на "Disable Sharing"
4. Меняем порт с "443", например, на "40404"
5. Жмем на "Enable Sharing"
6. Перезагружаем Денвер
kodar:
Промучился несколько дней на своей win 7 64 бит и, наконец, нашел решение. Дэнвер не запускался из-за конфликтов с прокси. Делаем так:
Панель управления -> Свойства обозревателя -> Вкладка "Подключения" -> кнопка "Настройка сети" -> Ставим галочку "Не использовать прокси-сервер для локальных адресов" и жмем Ок. Все, после этого заработало.
qroonqroonn:
I think that the authors say is very right, especially the views of the author close to our daily life.So we can go to the:[URL=http://www.fifa16coinsmall.com/]FIFA 16 Coins[/URL] or [URL=http://www.2maplestory.com/]Maplestory2 Mesos[/URL] and [URL=http://www.rsgpfast.com/]Runescape Gold[/URL]for study more.
VELESTOR: Открываем 80й порт в Windows 7, 8, 10 за 5 секунд
РЕШЕНО!

Нужно всего лишь перекинуть http.sys c IPv4 на IPv6
Написал краткую инструкция http://velestor.com/q/port80/
У меня Windows 10, помог только этот вариант, всем удачи!

Эта тема на forum.dklab.ru