Эта тема на forum.dklab.ru


access85: Windows 7 x64 и denwer
Может кто подскажет как запустить денвер на Windows 7 x64? Установится то он установился, а вот с запуском проблема, так как сам файл host лежит тут (Windows\winsxs\amd64_microsoft-windows-w..nfrastructure-other_31bf3856ad364e35_6.1.7600.16385_none_6079f415110c0210\) и никак его нельзя изменить, но и сам денвер не знает що файл тут, он ищет его в (system32\drivers\etc). Кто подскажет как быть?
AidarJan:
а вот с запуском проблема - а в чем собственно проблема то?
Относительно файла hosts на Windows 7 x64 вот ссылка на статью
Where is the Hosts File on Windows x64?

Вкратце: файл hosts находится по тому же адресу, что и прежде:

%systemroot%\system32\drivers\etc

или
%Windir%\System32\drivers\etc

как правило:
C:\Windows\System32\drivers\etc

Так вот, суть заключается в том, что для избежания конфликтов разработчики сохранили название директории "system32" и в 64-битных системах. Между тем, при осуществлении доступа к директории \system32 из 32-битного приложения система не покажет "ненативные" (неродные для 32-битного приложения) объекты находящиеся в этой директории и перенаправляет пользователя по соответствующему пути. При этом директория etc скрыта от просмотра.

Для получения доступа к файлу hosts необходимо использовать 64-битное приложение, в статье приводится пример:

Нажмите кнопку Пуск, наберите notepad и нажмите CTRL+SHIFT+ENTER, согласитесь запустить приложение в диалоговом окне UAC.
Нажмите CTRL+O, перейдите по пути C:\Windows\System32\drivers\etc, выберите в фильтре показа типов файлов "Все файлы".
Теперь вы видите файл hosts, откройте его и отредактируйте как вам угодно.


Можно пойти более простым путем:
Нажимаем Win+R (выполнить) вводим "C:\Windows\System32\drivers\etc" и выполняем, в итоге наш проводник откроет содержимое директории и можем оперировать с файлом hosts.
C:\Windows\System32\drivers\etc

P.S. Denwer два года без проблем работает на Windows 7 x64 Enterprise, при этом приходится временами использовать "переносную" рабочую площадку и на системах x32. Т.е. одна и та же настройка работает на разных системах.
Maus:
Перенесено из форума: Базовый пакет :: Денвер.
Перенесено в форум: Полезные советы :: Денвер.
Rekod:
Получается так, что при запуске Денвера на Windows 7 x64 с помощью ярлыка Run сайты на локальном компьютере не подключаются,
а чтобы подключить надо вручную каждый раз редактировать файл hosts?
Дмитрий Котеров:
У меня Windows 7 x64, и все работает нормально. Я думаю, у вас проблема в чем-то еще. Может быть, у вас антивирус блокирует запись в hosts, или еще что-то?
Rekod:
Ставил на чистую Windows 7 x64. Может мешал ее брандмауэр.
Вернулся на Vista 32. Проблемы перенесем на осень и зиму :)
kanich:
У меня Windows 7 x64, и все работает нормально. Я думаю, у вас проблема в чем-то еще. Может быть, у вас антивирус блокирует запись в hosts, или еще что-то?
У меня denwer стоит на Windows xp sp3 работает нормально, но на Windows 7 x64 Максимальная не работает. Установка проходит нормально, ярлыки запуска появляются, сам denwer запускается, а далее в браузер ввожу localhost и тишина не показывает стартовую страницу denwera. Может проблема в антивирусе Eset Smart Security 5. Фаерволл, самозащиту и все что может блокировать выход на локалхост пробовал отключать. Кто может помочь советом?

Вопрос решен, тему можно закрыть.
arbit:
Здравствуйте!
Извините за беспокойство.
В своем посте на форуме вы писали:
"У меня denwer стоит на Windows xp sp3 работает нормально, но на Windows 7 x64 Максимальная не работает. Установка проходит нормально, ярлыки запуска появляются, сам denwer запускается, а далее в браузер ввожу localhost и тишина не показывает стартовую страницу denwera. Может проблема в антивирусе Eset Smart Security 5. Фаерволл, самозащиту и все что может блокировать выход на локалхост пробовал отключать. Кто может помочь советом?"


У мнея аналогичная проблема.
Windows 7.
Denwer инсталлирован корректно.Запускается.
Но стартовая страница по адресу http://localhost не отображается. Выдается ошибка о недоступности страницы
Подскажите пожалуйста как Вы решили таку пробюлему?
Заранее благодарен!.
dUha:
Это все не проблема! просто запускайте от имени Администратора и все работает!!
Jess:
Минуту назад переустановил денвер и запустил от имени администратора - нифига он не работает.
SEka_SEka:
Всем по привету, у меня такая проблема установил Денвер запустилась но в команде пишется ошибка установка продолжается не удалось обновить hosts а сервер будет работать только адрес localhost, не пойму у меня винда 7 х64, покопался нашел что можно изменить что можно права для чтения изменить, но при запуске денвера она уберается помогите плиз
taichi: Установка Денвер на WIN7x64
Всем по привету, у меня такая проблема установил Денвер запустилась но в команде пишется ошибка установка продолжается не удалось обновить hosts а сервер будет работать только адрес localhost, не пойму у меня винда 7 х64, покопался нашел что можно изменить что можно права для чтения изменить, но при запуске денвера она уберается помогите плиз Сам столкнулся с аналогичной проблемой. При установке Денвер на WIN7x64 появлялась ошибка №5 (Скрин файла во вложении). Очень помогло сообщение по ссылке http://comp-team.narod.ru/error5.html.
Judge: вырубается Apache
Доброго времени суток! Установил Denwer, всё стало без проблем ни единой ошибки. Система Win7 x64. Запускаю с ярлыка, всё стартует (рис1).
В трее всё появляется как запущеное (рис2).
Запускаю браузер, набераю localhost или 127.0.0.1 , без разницы, не работает и Apache нет уже в трее (рис3).
Останавливаю Denwer с помощью ярлыка "Stop Denwer" и в открывшемся окне вижу надпись что Apache не запущен (рис4).

p.s.: Прошу сильно не пинать, я новичок, начал изучать самостоятельно!
Заранее спасибо всем кто откликнется!
Judge:
и рис4.
Judge:
На 127.0.0.1 пингуется
Файл Hosts правельный....


Разобрался !!!VMware сидел на 443 порту, сменил на 444 и заработало, что при вводе http://localhost, что при вводе 127.0.0.1
White_Tiger:
Добрый день, проблема как и у всех апач с грохотом падает спустя 30 секунд работы. (ни значка в трее ни процесса в диспечере).
теперь чуточку подробнее. Изначально денвер стоял на WIN XP и всё было замечательно, потом мне на работе выдали новую железяку до WIN 7 64x, накатил на неё денвер из под админа, установка прошла успешно. Сейчас запускаю из под админа же, апач стартует но через 30 секунд работы вываливается. Упоминаю заранее:
- антивирус и скайп снёс для чистоты эксперимента;
- netstat утверждает что порт свободен;
- никаких пока собственных папок с хитрыми .htaccess не заводил;
- денвер стоит "как есть" без каких либо сторонних вмешательств (последняя доступная на данном сайте версия);
- прокси отключен,
но апач продолжает вылетать. Что это может быть? И почему только при смене винды такая радость (ставил дома на XP же работает)?
VELESTOR: Открываем 80й порт в Windows 7, 8, 10 за 5 секунд
РЕШЕНО!

Нужно всего лишь перекинуть http.sys c IPv4 на IPv6
Написал краткую инструкция http://velestor.com/q/port80/
У меня Windows 10, помог только этот вариант, всем удачи!

Эта тема на forum.dklab.ru