Эта тема на forum.dklab.ru


fmr: Непонятный глюк
Ситуация следующая. Подключаю на сервере страницу при помощи require c фрагментом html кода, первая скобка < почему-то игнорируется и вылазит код. Ситуацию временно решил удвоением первой скобки <<, хотя это ненормально. Что это может быть?
Юрий Насретдинов:
Гхм... Как всегда ничего не понятно из вопроса... Вы что, настолько медленно печатаете, что Вам полчаса раскрывать суть вопроса, показать пример, который не работает, и т.д. ???
fmr:
Есть шаблон страницы, на котором надо разместить шапку с логотипом, поскольку страниц будет много, подключаю к шаблону файл при помощи require. Так вот, при выводе страницы шаблона в подключенном файле почему-то корежится код до неузнаваемости. Я на всякий случай кидаю ссылку http://www.klinokmag.com.ua/articles/weapon/art_1.htm, где это все можно увидеть. В чем причина так и не понял. Может какое-то кэширование - непонятно. Если у Вас все покажет без глюков - буду здесь искать причину. У меня подключение через прокси-сервер. Как нажму "Обновить" глючный код изменяется. Еще посмотрю эту страницу дома - там подключение без прокси
Дмитрий Котеров:
Действительно, корежится. Не хватает "<" у тэгов a, div, table. Они у Вас все подключаются по require?.. Попробуйте include, что ли...
fmr:
Дома тоже самое. Завтра попробую подключить файлы не по http://... а по пути на диске, может в этом причина глюка, посмотрю и напишу.
Дмитрий Котеров:
Ну конечно же, надо подключать не по http. Это оптимальнее раз в сто.
fmr:
Точно, так и есть. Подключил проверил - все получилось. Спасибо!

Эта тема на forum.dklab.ru