Форум dkLab и Denwer
Здесь общаются Web-разработчики.
Генеральный спонсор:
Хостинг «Джино»

Не грузится Localhost (EgoRk@, оценка: 8)
Goto page Previous  1, 2, 3 ... 14, 15, 16, 17, 18  Next
Author Message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9989
   поощрить/наказать


PostPosted: Fri Feb 03, 2012 5:22 pm (написано за 1 минуту 37 секунд)
   Post subject:
Reply with quote

Bbb wrote:
подскажите в каком направлении копать...
— читать эту тему с самого начала.

P.S. Ну, или в поиск сходить по тексту ошибки: Сходите, пожалуйста, в Поиск по запросу «Unable to connect child stdout to NUL». Спасибо!
Back to top
View user's profile Send private message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9989
   поощрить/наказать


PostPosted: Sun Feb 12, 2012 1:43 pm (спустя 8 дней 20 часов 20 минут)
   Post subject:
Reply with quote


М

Ветка выделена в отдельную тему «Все перечитал ответа не нашел.»,
расположенную в форуме Мусоропровод (12 Февраля 2012, 14:43).
Back to top
View user's profile Send private message
Alexakashark
Заглянувший



Joined: 16 Feb 2012
Posts: 6
Карма: -1
   поощрить/наказать

Location: Montenegro

PostPosted: Thu Feb 16, 2012 12:58 pm (спустя 3 дня 23 часа 14 минут; написано за 20 минут 22 секунды)
   Post subject:
Reply with quote

Добрый день, Господа!
Сил уж нет заставить работать Денвер на Винде 7 Домашняя базовая SP1, а точнее не грузится ни localhost во всех комбинациях, ни test1.ru - ни чего! Мол "поищите в Инете"...
ЖЕСТЬ КОРОЧЕ!!! :( Перечитал Ваш форум и все возможные темы - и все тихо!
Скачал с сайта Denwer3_Base_2010-11-07_a2.2.4_p5.3.1_m5.1.40_pma3.2.3
Делал уже все, что рекомендовано на форуме, только что Винду не переставлял. Но по порядку:
стоит антивирь Eset 4 - все изменения и исключения внесены.
стоит Скайп - порты 80 и 443 исключены.
ФайерВол - нет, кроме NOD-кого и в нем внес изменения ввиде исключений.
Прокси - нет, все соответствующие изменения сделаны (Ишак, Опера, ЛисаОгненая)
DNS - все работает в автомате.
IIS - отключено все.
Брендмауер Винды отключен - включал его, внося исключения во входящие и исходящие трафики - не помогло.
Пингуется как localhost так и 127.0.0.1, netstat -anb - 80 не занят.
в файле Host - Денвер внес все что нужно, я даже раз удалял его, переуставливал Денвер - он его восстановил
вот текст:

127.0.0.1 localhost
127.0.0.1 www.subdomain.localhost
127.0.0.1 www.subdomain.test1.ru
127.0.0.1 www.Tools.localhost
127.0.0.1 subdomain.localhost
127.0.0.1 subdomain.test1.ru
127.0.0.1 Tools.localhost
127.0.0.1 www.localhost
127.0.0.1 www.test1.ru
127.0.0.2 custom-host
127.0.0.2 www.custom
127.0.0.1 test1.ru
127.0.0.2 custom

и прописал что надо, с правами у файла все - ок.
Сервер поставлен на доп.раздел (кстати, ставил на флешку и на винт-usb - так же не пошел)
При клике в трее на перо - выдает окно с такой надписью:

[notice] Disable use of AcceptEx() WinSock2 API

А это лог:
[Thu Feb 16 10:40:51 2012] [warn] Init: SSL server IP/port conflict: test1.ru:443 (I:/usr/local/apache/conf/vhosts.conf:131) vs. Tools.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:154)
[Thu Feb 16 10:40:51 2012] [warn] Init: SSL server IP/port conflict: subdomain.test1.ru:443 (I:/usr/local/apache/conf/vhosts.conf:108) vs. Tools.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:154)
[Thu Feb 16 10:40:51 2012] [warn] Init: SSL server IP/port conflict: subdomain.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:85) vs. Tools.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:154)
[Thu Feb 16 10:40:51 2012] [warn] Init: SSL server IP/port conflict: localhost:443 (I:/usr/local/apache/conf/vhosts.conf:39) vs. Tools.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:154)
[Thu Feb 16 10:40:51 2012] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
[Thu Feb 16 10:40:52 2012] [warn] Init: SSL server IP/port conflict: test1.ru:443 (I:/usr/local/apache/conf/vhosts.conf:131) vs. Tools.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:154)
[Thu Feb 16 10:40:52 2012] [warn] Init: SSL server IP/port conflict: subdomain.test1.ru:443 (I:/usr/local/apache/conf/vhosts.conf:108) vs. Tools.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:154)
[Thu Feb 16 10:40:52 2012] [warn] Init: SSL server IP/port conflict: subdomain.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:85) vs. Tools.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:154)
[Thu Feb 16 10:40:52 2012] [warn] Init: SSL server IP/port conflict: localhost:443 (I:/usr/local/apache/conf/vhosts.conf:39) vs. Tools.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:154)
[Thu Feb 16 10:40:52 2012] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
[Thu Feb 16 10:40:52 2012] [notice] Apache/2.2.4 (Win32) mod_ssl/2.2.4 OpenSSL/0.9.8k PHP/5.3.3 configured -- resuming normal operations
[Thu Feb 16 10:40:52 2012] [notice] Server built: Jan 9 2007 23:17:20
[Thu Feb 16 10:40:52 2012] [notice] Parent: Created child process 4896
[Thu Feb 16 10:40:52 2012] [notice] Disabled use of AcceptEx() WinSock2 API
[Thu Feb 16 10:40:52 2012] [warn] Init: SSL server IP/port conflict: test1.ru:443 (I:/usr/local/apache/conf/vhosts.conf:131) vs. Tools.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:154)
[Thu Feb 16 10:40:52 2012] [warn] Init: SSL server IP/port conflict: subdomain.test1.ru:443 (I:/usr/local/apache/conf/vhosts.conf:108) vs. Tools.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:154)
[Thu Feb 16 10:40:52 2012] [warn] Init: SSL server IP/port conflict: subdomain.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:85) vs. Tools.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:154)
[Thu Feb 16 10:40:52 2012] [warn] Init: SSL server IP/port conflict: localhost:443 (I:/usr/local/apache/conf/vhosts.conf:39) vs. Tools.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:154)
[Thu Feb 16 10:40:52 2012] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
[Thu Feb 16 10:40:53 2012] [warn] Init: SSL server IP/port conflict: test1.ru:443 (I:/usr/local/apache/conf/vhosts.conf:131) vs. Tools.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:154)
[Thu Feb 16 10:40:53 2012] [warn] Init: SSL server IP/port conflict: subdomain.test1.ru:443 (I:/usr/local/apache/conf/vhosts.conf:108) vs. Tools.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:154)
[Thu Feb 16 10:40:53 2012] [warn] Init: SSL server IP/port conflict: subdomain.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:85) vs. Tools.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:154)
[Thu Feb 16 10:40:53 2012] [warn] Init: SSL server IP/port conflict: localhost:443 (I:/usr/local/apache/conf/vhosts.conf:39) vs. Tools.localhost:443 (I:/usr/local/apache/conf/vhosts.conf:154)
[Thu Feb 16 10:40:53 2012] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
[Thu Feb 16 10:40:53 2012] [notice] Child 4896: Child process is running
[Thu Feb 16 10:40:53 2012] [notice] Child 4896: Acquired the start mutex.
[Thu Feb 16 10:40:53 2012] [notice] Child 4896: Starting 25 worker threads.
[Thu Feb 16 10:40:53 2012] [notice] Child 4896: Listening on port 443.
[Thu Feb 16 10:40:53 2012] [notice] Child 4896: Listening on port 8648.
[Thu Feb 16 10:40:53 2012] [notice] Child 4896: Listening on port 443.
[Thu Feb 16 10:40:53 2012] [notice] Child 4896: Listening on port 80.

Господа, есть какие нить предположения?! Кроме тех, что на форуме уже озвучены?
А то работать надо, и все ТИХО...
Кстати, он же работал до этого, пока винт по гарантии на ноутене накрылся. Поменял на такой же,
восстановил Винду (с бекапных дисков), поставил все тоже, что и было...
Back to top
View user's profile Send private message
Alexakashark
Заглянувший



Joined: 16 Feb 2012
Posts: 6
Карма: -1
   поощрить/наказать

Location: Montenegro

PostPosted: Thu Feb 16, 2012 1:21 pm (спустя 23 минуты; написано за 2 секунды)
   Post subject:
Reply with quote

Вот результат по netstat:


ЂЄвЁў­лҐ Ї®¤Є«о祭Ёп

  ?¬п ‹®Є «м­л©  ¤аҐб ‚­Ґи­Ё©  ¤аҐб ‘®бв®п­ЁҐ
  TCP 0.0.0.0:135 0.0.0.0:0 LISTENING
  RpcSs
 [svchost.exe]
  TCP 0.0.0.0:445 0.0.0.0:0 LISTENING
 ЌҐ г¤ Ґвбп Ї®«гзЁвм ᢥ¤Ґ­Ёп ® ў« ¤Ґ«мжҐ
  TCP 0.0.0.0:1034 0.0.0.0:0 LISTENING
 [Skype.exe]
  TCP 0.0.0.0:5357 0.0.0.0:0 LISTENING
 ЌҐ г¤ Ґвбп Ї®«гзЁвм ᢥ¤Ґ­Ёп ® ў« ¤Ґ«мжҐ
  TCP 0.0.0.0:49152 0.0.0.0:0 LISTENING
 [wininit.exe]
  TCP 0.0.0.0:49153 0.0.0.0:0 LISTENING
  eventlog
 [svchost.exe]
  TCP 0.0.0.0:49154 0.0.0.0:0 LISTENING
  Schedule
 [svchost.exe]
  TCP 0.0.0.0:49155 0.0.0.0:0 LISTENING
 [lsass.exe]
  TCP 0.0.0.0:49156 0.0.0.0:0 LISTENING
 [services.exe]
  TCP 0.0.0.0:49157 0.0.0.0:0 LISTENING
  PolicyAgent
 [svchost.exe]
  TCP 127.0.0.1:25 0.0.0.0:0 LISTENING
 [miniperl.exe]
  TCP 127.0.0.1:80 0.0.0.0:0 LISTENING
 [httpd.exe]
  TCP 127.0.0.1:443 0.0.0.0:0 LISTENING
 [httpd.exe]
  TCP 127.0.0.1:3306 0.0.0.0:0 LISTENING
 [mysqld.exe]
  TCP 127.0.0.1:49344 0.0.0.0:0 LISTENING
 [UNS.exe]
  TCP 127.0.0.2:443 0.0.0.0:0 LISTENING
 [httpd.exe]
  TCP 127.0.0.2:8648 0.0.0.0:0 LISTENING
 [httpd.exe]
  TCP 192.168.1.34:139 0.0.0.0:0 LISTENING
 ЌҐ г¤ Ґвбп Ї®«гзЁвм ᢥ¤Ґ­Ёп ® ў« ¤Ґ«мжҐ
  TCP 192.168.1.34:49631 109.226.65.9:41327 ESTABLISHED
 [Skype.exe]
  TCP 192.168.1.34:49639 193.120.199.15:443 ESTABLISHED
 [Skype.exe]
  TCP 192.168.1.34:49662 64.4.61.167:80 ESTABLISHED
 [iexplore.exe]
  TCP 192.168.1.34:49761 213.186.127.42:1935 ESTABLISHED
 [opera.exe]
  TCP 192.168.1.34:50114 77.88.21.11:80 TIME_WAIT
  TCP 192.168.1.34:50130 91.203.99.45:80 TIME_WAIT
  TCP 192.168.1.34:50133 74.125.232.250:80 TIME_WAIT
  TCP 192.168.1.34:50138 74.125.232.249:80 ESTABLISHED
 [opera.exe]
  TCP 192.168.1.34:50139 74.125.232.250:80 TIME_WAIT
  TCP 192.168.1.34:50147 74.125.232.234:80 ESTABLISHED
 [opera.exe]
  TCP 192.168.1.34:50151 74.125.232.249:80 ESTABLISHED
 [opera.exe]
Back to top
View user's profile Send private message
Alexakashark
Заглянувший



Joined: 16 Feb 2012
Posts: 6
Карма: -1
   поощрить/наказать

Location: Montenegro

PostPosted: Thu Feb 16, 2012 4:18 pm (спустя 2 часа 56 минут; написано за 3 минуты 26 секунд)
   Post subject:
Reply with quote

telnet localhost 80 написал сегодня, впервые: Неудалось открыть подключение к этому узлу, на порт 80: Сбой подключения.
до этого просто чистый экран с курсором в углу. Ни чего не ставил из софта и не убирал.
тут же запускаю netstat -anp - и результат тот же, что и выше был приведен мной.
Каким софтом можно глянуть что висит на 80?
Спасибо заранее!
Back to top
View user's profile Send private message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9989
   поощрить/наказать


PostPosted: Thu Feb 16, 2012 6:11 pm (спустя 1 час 53 минуты; написано за 27 секунд)
   Post subject:
Reply with quote

Alexakashark wrote:
Каким софтом можно глянуть что висит на 80?
— так Вам же уже показали:
Quote:
TCP 127.0.0.1:80 0.0.0.0:0 LISTENING
 [httpd.exe]
Back to top
View user's profile Send private message
Alexakashark
Заглянувший



Joined: 16 Feb 2012
Posts: 6
Карма: -1
   поощрить/наказать

Location: Montenegro

PostPosted: Thu Feb 16, 2012 6:32 pm (спустя 20 минут; написано за 2 минуты 46 секунд)
   Post subject:
Reply with quote

Уважаемый bæv, я допустил ошибку.
Объясню - telnet localhost 80 был запущен при работающем Апаче, соответственно и получил TCP 127.0.0.1:80 0.0.0.0:0 LISTENING [httpd.exe]
Остановил сервер, на netstat -anb получил следующее:

ЂЄвЁў­лҐ Ї®¤Є«о祭Ёп

  ?¬п ‹®Є «м­л©  ¤аҐб ‚­Ґи­Ё©  ¤аҐб ‘®бв®п­ЁҐ
  TCP 0.0.0.0:135 0.0.0.0:0 LISTENING
  RpcSs
 [svchost.exe]
  TCP 0.0.0.0:445 0.0.0.0:0 LISTENING
 ЌҐ г¤ Ґвбп Ї®«гзЁвм ᢥ¤Ґ­Ёп ® ў« ¤Ґ«мжҐ
  TCP 0.0.0.0:1034 0.0.0.0:0 LISTENING
 [Skype.exe]
  TCP 0.0.0.0:5357 0.0.0.0:0 LISTENING
 ЌҐ г¤ Ґвбп Ї®«гзЁвм ᢥ¤Ґ­Ёп ® ў« ¤Ґ«мжҐ
  TCP 0.0.0.0:49152 0.0.0.0:0 LISTENING
 [wininit.exe]
  TCP 0.0.0.0:49153 0.0.0.0:0 LISTENING
  eventlog
 [svchost.exe]
  TCP 0.0.0.0:49154 0.0.0.0:0 LISTENING
  Schedule
 [svchost.exe]
  TCP 0.0.0.0:49155 0.0.0.0:0 LISTENING
 [services.exe]
  TCP 0.0.0.0:49156 0.0.0.0:0 LISTENING
  PolicyAgent
 [svchost.exe]
  TCP 0.0.0.0:49157 0.0.0.0:0 LISTENING
 [lsass.exe]
  TCP 127.0.0.1:49160 0.0.0.0:0 LISTENING
 [UNS.exe]
  TCP 192.168.1.34:139 0.0.0.0:0 LISTENING
 ЌҐ г¤ Ґвбп Ї®«гзЁвм ᢥ¤Ґ­Ёп ® ў« ¤Ґ«мжҐ
  TCP 192.168.1.34:49163 157.56.52.33:40014 ESTABLISHED
 [Skype.exe]
  TCP 192.168.1.34:49165 213.146.189.201:12350 ESTABLISHED
 [Skype.exe]
  TCP 192.168.1.34:49376 64.4.61.48:80 ESTABLISHED
 [iexplore.exe]
  TCP 192.168.1.34:49743 178.218.214.74:1935 ESTABLISHED
 [opera.exe]
  TCP 192.168.1.34:49751 109.72.96.29:27781 ESTABLISHED
 [Skype.exe]
  TCP [::]:135 [::]:0 LISTENING
  RpcSs
 [svchost.exe]
  TCP [::]:445 [::]:0 LISTENING
 ЌҐ г¤ Ґвбп Ї®«гзЁвм ᢥ¤Ґ­Ёп ® ў« ¤Ґ«мжҐ
  TCP [::]:5357 [::]:0 LISTENING
 ЌҐ г¤ Ґвбп Ї®«гзЁвм ᢥ¤Ґ­Ёп ® ў« ¤Ґ«мжҐ
  TCP [::]:49152 [::]:0 LISTENING
 [wininit.exe]
  TCP [::]:49153 [::]:0 LISTENING
  eventlog
 [svchost.exe]
  TCP [::]:49154 [::]:0 LISTENING
  Schedule
 [svchost.exe]
  TCP [::]:49155 [::]:0 LISTENING
 [services.exe]
  TCP [::]:49156 [::]:0 LISTENING
  PolicyAgent
 [svchost.exe]
  TCP [::]:49157 [::]:0 LISTENING
 [lsass.exe]
  UDP 0.0.0.0:500 *:*
  IKEEXT
 [svchost.exe]
  UDP 0.0.0.0:1034 *:*
 [Skype.exe]
  UDP 0.0.0.0:3702 *:*
  FDResPub
 [svchost.exe]
  UDP 0.0.0.0:3702 *:*
  FDResPub
 [svchost.exe]
  UDP 0.0.0.0:4500 *:*
  IKEEXT
 [svchost.exe]
  UDP 0.0.0.0:5355 *:*
  Dnscache
 [svchost.exe]
  UDP 0.0.0.0:49152 *:*
  FDResPub
 [svchost.exe]
  UDP 127.0.0.1:1900 *:*
  SSDPSRV
 [svchost.exe]
  UDP 127.0.0.1:50139 *:*
 [iexplore.exe]
  UDP 127.0.0.1:50266 *:*
 [Skype.exe]
  UDP 127.0.0.1:55104 *:*
 [iexplore.exe]
  UDP 127.0.0.1:55782 *:*
  SSDPSRV
 [svchost.exe]
  UDP 127.0.0.1:58269 *:*
 [iexplore.exe]
  UDP 127.0.0.1:60808 *:*
 [Skype.exe]
  UDP 192.168.1.34:137 *:*
 ЌҐ г¤ Ґвбп Ї®«гзЁвм ᢥ¤Ґ­Ёп ® ў« ¤Ґ«мжҐ
  UDP 192.168.1.34:138 *:*
 ЌҐ г¤ Ґвбп Ї®«гзЁвм ᢥ¤Ґ­Ёп ® ў« ¤Ґ«мжҐ
  UDP 192.168.1.34:1900 *:*
  SSDPSRV
 [svchost.exe]
  UDP 192.168.1.34:1900 *:*
 [opera.exe]
  UDP 192.168.1.34:55105 *:*
 [opera.exe]
  UDP 192.168.1.34:55781 *:*
  SSDPSRV
 [svchost.exe]
  UDP [::]:500 *:*
  IKEEXT
 [svchost.exe]
  UDP [::]:3702 *:*
  FDResPub
 [svchost.exe]
  UDP [::]:3702 *:*
  FDResPub
 [svchost.exe]
  UDP [::]:4500 *:*
  IKEEXT
 [svchost.exe]
  UDP [::]:49153 *:*
  FDResPub
 [svchost.exe]
  UDP [::1]:1900 *:*
  SSDPSRV
 [svchost.exe]
  UDP [::1]:55780 *:*
  SSDPSRV
 [svchost.exe]

а при telnet localhost 80 при остановленном сервере выдает ту же ошибку как и до: Неудалось открыть подключение к этому узлу, на порт 80: Сбой подключения.
Back to top
View user's profile Send private message
Alexakashark
Заглянувший



Joined: 16 Feb 2012
Posts: 6
Карма: -1
   поощрить/наказать

Location: Montenegro

PostPosted: Thu Feb 16, 2012 6:34 pm (спустя 2 минуты; написано за 1 минуту 4 секунды)
   Post subject:
Reply with quote

Спасибо за понимание! Просто ОЧЕНЬ нужно, чтобы все работало... :( встала работа...
Back to top
View user's profile Send private message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9989
   поощрить/наказать


PostPosted: Thu Feb 16, 2012 9:02 pm (спустя 2 часа 27 минут; написано за 10 секунд)
   Post subject:
Reply with quote

Alexakashark wrote:
Остановил сервер, на netstat -anb получил следующее
— ничто не занимает 80-й порт.
Смотрите каким-нибудь сниффером (я предпочитаю SmartSniff), что реально отвечает на запросы к localhost. Смотрите при запущенном Денвере.
Back to top
View user's profile Send private message
Alexakashark
Заглянувший



Joined: 16 Feb 2012
Posts: 6
Карма: -1
   поощрить/наказать

Location: Montenegro

PostPosted: Fri Feb 17, 2012 1:23 pm (спустя 16 часов 21 минуту; написано за 48 секунд)
   Post subject:
Reply with quote

Спасибо за совет! Уже так и сделал и ничего не нашел, порт свободный.... я в шоке :(((
Потом сделал следующее, взял у жены старый бук с XP SP3 и на нем поставил денвер - все заработало на раз (кстати, даже не вносил изменения в настройки Скайпа!)!
У нее на компе стоит NOD32 4.0 Antivirus.
И уже совсем отчаявщийсь, решил снести NOD32 4.0 Smart security и поставил NOD32 4.0 Antivirus, обновил винду через центр обновлений - вуаля!!! Заработало!
Отправил письмо в службу поддержки антивиря, жду от них ответ.
Одно осталось загадкой, почему даже сниффер не дал результат?! Ведь типа порт был свободен!!!

Огромное спасибо за помощь!
Back to top
View user's profile Send private message
Denyros
Заглянувший



Joined: 17 Feb 2012
Posts: 5
Карма: -1
   поощрить/наказать


PostPosted: Fri Feb 17, 2012 9:49 pm (спустя 8 часов 25 минут; написано за 50 секунд)
   Post subject:
Reply with quote

Не могу справиться с проблемой:
При установке Denwer не заметил, что у меня уже есть сетевой диск Z: и установил виртуальный поверх его.
Denwer установился, все функционировало.
После выхода из Denwer у меня переименовался диск C: на название сетевого диска Z:, после чего я удалил сетевой диск, потом удалил папку C:\WebServers
Установил Denwer заново на диск Z:
При попытке загрузить localhost в браузере подвисает белое окно. Другие локальные хосты тоже не загружаются.
= Версия Windows 7 х64 домашняя расширенная SP1
= Синтаксис netstat -nb > C:\netstat.txt не воспринимается командной строкой
netstat без параметров выдает в окне TCP 10.48.1.45:54837 mrim47:2041 ESTABLISHED и еще штук 20 строк (рабочая локальная сеть)
= Файла /usr/local/apache/logs/error.log нет на виртуальном диске
= Содержимое файла /windows/system32/drivers/etc/hosts
127.0.0.1 localhost
127.0.0.1 www.subdomain.localhost
127.0.0.1 www.subdomain.test1.ru
127.0.0.1 www.Tools.localhost
127.0.0.1 subdomain.localhost
127.0.0.1 subdomain.test1.ru
127.0.0.1 Tools.localhost
127.0.0.1 www.localhost
127.0.0.1 www.test1.ru
127.0.0.2 custom-host
127.0.0.2 www.custom
127.0.0.1 test1.ru
127.0.0.2 custom
Брэндмауэр и антивирус отключал, не помогает.
Прошу помощи.
Back to top
View user's profile Send private message
Maus
Модератор



Joined: 29 Jun 2003
Posts: 8151
Карма: 271
   поощрить/наказать

Location: пос. Омсукчан Магаданской области

PostPosted: Fri Feb 17, 2012 10:32 pm (спустя 42 минуты; написано за 3 минуты 22 секунды)
   Post subject:
Reply with quote

Denyros
Остановите Денвер.
Удалите из hosts все строки, кроме первой:
Denyros wrote:
127.0.0.1 www.subdomain.localhost
127.0.0.1 www.subdomain.test1.ru
127.0.0.1 www.Tools.localhost
127.0.0.1 subdomain.localhost
127.0.0.1 subdomain.test1.ru
127.0.0.1 Tools.localhost
127.0.0.1 www.localhost
127.0.0.1 www.test1.ru
127.0.0.2 custom-host
127.0.0.2 www.custom
127.0.0.1 test1.ru
127.0.0.2 custom
удалите папку инсталляции и ярлыки. Перезагрузитесь. Попробуйте установить снова, лучше - на другую букву диска (Y:,W:... любую). Если при запуске комплекса файл error.log не создаётся, остановите, создайте вручную, проверьте права, запустите снова. Пока не пройдет корректный запуск - кина не будет.
Back to top
View user's profile Send private message
Denyros
Заглянувший



Joined: 17 Feb 2012
Posts: 5
Карма: -1
   поощрить/наказать


PostPosted: Fri Feb 17, 2012 11:14 pm (спустя 42 минуты; написано за 2 минуты 10 секунд)
   Post subject:
Reply with quote

Все проделал, но результат тот же.
Создал пустой файл error.log, после запуска Денвера он исчез.
Есть вот такая инфа
(imglink.ru)
Back to top
View user's profile Send private message
Maus
Модератор



Joined: 29 Jun 2003
Posts: 8151
Карма: 271
   поощрить/наказать

Location: пос. Омсукчан Магаданской области

PostPosted: Fri Feb 17, 2012 11:21 pm (спустя 6 минут; написано за 1 минуту 18 секунд)
   Post subject:
Reply with quote

Denyros
Сходите, пожалуйста, в Гугль по запросу "os 10013". Спасибо! (www.google.ru/search?q=os+10013)
Там по-английски, правда. Вкратце содержимое первой ссылки: или порт чем-то занят, или файрволл запрещает. Дальше гуглите сами, это слишком увлекательно.
Back to top
View user's profile Send private message
Denyros
Заглянувший



Joined: 17 Feb 2012
Posts: 5
Карма: -1
   поощрить/наказать


PostPosted: Fri Feb 17, 2012 11:30 pm (спустя 9 минут; написано за 2 минуты 15 секунд)
   Post subject:
Reply with quote

Maus
спасибо за помощь, постараюсь разобраться
Back to top
View user's profile Send private message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9989
   поощрить/наказать


PostPosted: Sat Feb 18, 2012 7:16 am (спустя 7 часов 45 минут; написано за 8 секунд)
   Post subject:
Reply with quote

Denyros: Сходите, пожалуйста, в Поиск по запросу «make_sock could not bind to address». Спасибо!
Back to top
View user's profile Send private message
Denyros
Заглянувший



Joined: 17 Feb 2012
Posts: 5
Карма: -1
   поощрить/наказать


PostPosted: Sat Feb 18, 2012 10:59 am (спустя 3 часа 43 минуты; написано за 4 минуты 59 секунд)
   Post subject:
Reply with quote

Прочитал все предложенные варианты решений, существенно обогатился знаниями :) , но порт :80 ничем не был занят, пытался менять порт - ничего; антивир, скайп, файрвол, IIS - выключены.
Проблему решил тупым откатом системы на пару дней назад.
Back to top
View user's profile Send private message
sonoleo
Заглянувший



Joined: 23 Feb 2012
Posts: 2
Карма: -1
   поощрить/наказать


PostPosted: Sun Feb 26, 2012 10:43 am (спустя 7 дней 23 часа 44 минуты; написано за 3 минуты 36 секунд)
   Post subject:
Reply with quote

Добрый день, после запуска денвера перо через 30 сек исчезает. На localhost выдает "Не удается найти требуемую страницу". Переключаюсь на денвер-2 - всё в порядке. Где-то встречал такую ошибку (1-ю), но сейчас найти не могу. Дайте ответ или ссылку где обсуждается исчезающее "перо".
Back to top
View user's profile Send private message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9989
   поощрить/наказать


PostPosted: Sun Feb 26, 2012 10:52 am (спустя 9 минут; написано за 20 секунд)
   Post subject:
Reply with quote

sonoleo, перечитывайте эту тему с самого начала.
Back to top
View user's profile Send private message
velikijmerlin
Заглянувший



Joined: 08 Jan 2011
Posts: 4
Карма: -1
   поощрить/наказать


PostPosted: Fri Mar 02, 2012 8:47 pm (спустя 5 дней 9 часов 55 минут; написано за 1 минуту 16 секунд)
   Post subject:
Reply with quote

здравствуйте, была така яже проблема... как и выше, благо прочитав последнюю страницу понял в чём трабла и вспомнил что может мешать... оказалось VMWorkstation 8 от сюда вопрос, как совместить двух зверьком ? Денвер и воркстейшн?
Back to top
View user's profile Send private message
sonoleo
Заглянувший



Joined: 23 Feb 2012
Posts: 2
Карма: -1
   поощрить/наказать


PostPosted: Sat Mar 03, 2012 8:01 pm (спустя 23 часа 13 минут; написано за 8 минут 51 секунду)
   Post subject:
Reply with quote

sonoleo wrote:
Добрый день, после запуска денвера перо через 30 сек исчезает. На localhost выдает "Не удается найти требуемую страницу". Переключаюсь на денвер-2 - всё в порядке. Где-то встречал такую ошибку (1-ю), но сейчас найти не могу. Дайте ответ или ссылку где обсуждается исчезающее "перо".
В службах компонентов нашел IIS Admin (Позволяет администрировать веб- и FTP-службы с помощью оснастки IIS). Тип запуска "авто", остановил. Дважды перезапустил Денвер. И после запуска localhost/ сработало и выдала "Ура, заработала!". Тип запуска службы перевёл "Авто" в "Отключено". Под Денвер-2 это не мешало. IIS запущен раньше нужен был для работы с ASP. Проверяю дальше.
Back to top
View user's profile Send private message
ProMiNick
Заглянувший



Joined: 07 Mar 2012
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Wed Mar 07, 2012 10:47 am (спустя 3 дня 14 часов 46 минут; написано за 9 минут 35 секунд)
   Post subject:
Reply with quote

Тупил сутки, после читал этот форум.
так как в командной строке запрос netstat -anb выдал следующее
TCP 0.0.0.0:80 LISTENING 80 System ; т.е занят чем то 80 порт, притом раз процесс System то занят службой.
Помогло поискать инфу какой процесс сидит на 80 порту
оказалась Служба веб-публикаций.

P.S. Чтобы не ломать голову в дебрях служб, если комп Ваш, предварительно переставте винду дабы не осталось сюрпризов от предыдущих пользователей.
Back to top
View user's profile Send private message
melomanoff
Заглянувший



Joined: 12 Mar 2012
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Mon Mar 12, 2012 7:25 pm (спустя 5 дней 8 часов 38 минут; написано за 6 минут 44 секунды)
   Post subject:
Reply with quote

У кого стоит windows 7 и не грузится localhost, но грузятся test1.ru, рекомендую, если у вас установлена видеокарта NVIDIA и стоит nvidia nerwork manager, удалить эту софтину и проблема может быть будет решена ( у меня по крайней мере была решена).
Может быть эта информация будет кому-нибудь полезна, потому как, чтобы решить эту проблему, и отключал брандмауэер, и выключал практически все службы, и отключал uac, но резульата не было.
ps.В win xp при установленном nvidia network manager все работало, стоило перейти на 7 и возникла такая шляпа. В итоге провозился с ней 2 вечера и пол дня.) )
Back to top
View user's profile Send private message
StreamFor
Заглянувший



Joined: 02 Apr 2012
Posts: 2
Карма: -1
   поощрить/наказать


PostPosted: Mon Apr 02, 2012 4:09 pm (спустя 20 дней 20 часов 44 минуты; написано за 2 минуты 44 секунды)
   Post subject:
Reply with quote

Добрый вечер. Начала ставить денвер. И запоролось...

[Sun Apr 01 19:15:34 2012] [notice] Child 4300: Child process is running
[Sun Apr 01 19:15:34 2012] [notice] Child 4300: Acquired the start mutex.
[Sun Apr 01 19:15:34 2012] [notice] Child 4300: Starting 25 worker threads.
[Sun Apr 01 19:15:34 2012] [notice] Child 4300: Listening on port 443.
[Sun Apr 01 19:15:34 2012] [notice] Child 4300: Listening on port 8648.
[Sun Apr 01 19:15:34 2012] [notice] Child 4300: Listening on port 443.
[Sun Apr 01 19:15:34 2012] [notice] Child 4300: Listening on port 80.
[Sun Apr 01 19:15:52 2012] [error] [client 127.0.0.1] , referer: localhost/denwer/
[Sun Apr 01 19:23:02 2012] [error] [client 127.0.0.1] File does not exist: J:/home/test1.ru/www/favicon.ico, referer: test1.ru/
[Sun Apr 01 20:18:24 2012] [error] [client 127.0.0.1] , referer: localhost/denwer/

Вот на этом. В миниперле пишет последнюю строчку: Listening for connections on localhost:25...

Помогите, пожалуйста, разобраться, в чём затык.
Back to top
View user's profile Send private message
immortal727
Заглянувший



Joined: 12 May 2012
Posts: 2
Карма: -1
   поощрить/наказать


PostPosted: Sat May 12, 2012 5:27 pm (спустя 1 месяц 10 дней 1 час 17 минут; написано за 2 минуты 24 секунды)
   Post subject:
Reply with quote

Стоит Win7. Раньше все работало. Обновил, если как мне помнится скайп, все перестало работать. В нем убрал галочку чтобы порт 80 он не использовал, но к результату это не привело.
Также всё прочитал выше сказанное.
Отправил файл (пересохранил ево в doc) то что запущено на 80 порту.
В логе начинается следующими строками и т.п.
[Sat May 12 18:19:15 2012] [warn] Init: SSL server IP/port conflict: web-studio:443 (P:/usr/local/apache/conf/vhosts.conf:821) vs. wp:443
Что делать уже ума не приложу, помогите пожалуйста.


result.doc
 Description:

Download
 Filename:  result.doc
 Filesize:  33.5 KB
 Downloaded:  560 Time(s)

Back to top
View user's profile Send private message
Mihail11
Заглянувший



Joined: 20 May 2012
Posts: 1
Карма: -1
   поощрить/наказать


PostPosted: Sun May 20, 2012 6:45 am (спустя 7 дней 13 часов 17 минут; написано за 53 секунды)
   Post subject:
Reply with quote

Я не знаю по теме или нет, но все же

Можно ли установит cpanel на denwer?
Back to top
View user's profile Send private message
Goolfen
Заглянувший



Joined: 28 May 2012
Posts: 1
Карма: -1
   поощрить/наказать


PostPosted: Mon May 28, 2012 9:22 pm (спустя 8 дней 14 часов 37 минут; написано за 4 минуты 31 секунду)
   Post subject:
Reply with quote

Когда устанавливаю Денвер пишет:
Quote:
Утилита PING.EXE найдена, однако не удается выполнить команду:
ping localhost
Возможно, неправильно настроены драйверы сети. Выполните все рекомендации из статьи "Устанавливаем базовый комплект" по адресу denwer.tu/base.html
Данная ошибка также может возникать в случае, если в вашей системе работает фаервол <брандмауэр, межсетевой экран, firewall>, блокирующий протокол ICMP. Отключите блокирование ICMP на время установки Денвера.
Что делать подскажите.
Back to top
View user's profile Send private message
vlad-sheff
Заглянувший



Joined: 07 Jun 2012
Posts: 5
Карма: -2
   поощрить/наказать


PostPosted: Thu Jun 07, 2012 5:06 pm (спустя 9 дней 19 часов 43 минуты; написано за 1 минуту 24 секунды)
   Post subject:
Reply with quote

Здрасте
Установил Денвер 3. Все хорошо.
Но, не заходит на localhost в 2 браузерах- Опера и Хром. Там и там прокси не используется. Прикрепил скрин.
В хостах все есть.
Брандмаузер виключил, а антивирус удалил.
Ant wrote:
Значит так. Выполняете «cmd» (через «Выполнить...»). Далее вводите «telnet localhost 80». Если после этого все введённые надписи пропадают и остаётся мигающий курсор — всё в порядке — соединение есть (введите [печататься буквы не будут — только пустые места от них будут показаны] «GET» и нажмите Enter — увидите содержание страницы localhost/). Если же появляется надпись «Connecting To localhost...Could not open connection to the host, on port 80: Connect failed» (или тоже самое, но на русском языке — значит соединения нет).
Зделал, прикрепил скрин.
И што мне делать дальше?


2.png
 Description:
Opera
 Filesize:  243.28 KB
 Viewed:  46686 Time(s)

2.png



1.png
 Description:
Chrome
 Filesize:  184.04 KB
 Viewed:  46686 Time(s)

1.png



123.png
 Description:
telnet localhost 80
 Filesize:  56.65 KB
 Viewed:  46686 Time(s)

123.png


Back to top
View user's profile Send private message
Maus
Модератор



Joined: 29 Jun 2003
Posts: 8151
Карма: 271
   поощрить/наказать

Location: пос. Омсукчан Магаданской области

PostPosted: Fri Jun 08, 2012 6:18 pm (спустя 1 день 1 час 12 минут; написано за 13 секунд)
   Post subject:
Reply with quote

vlad-sheff
отключайте IIS
Back to top
View user's profile Send private message
vlad-sheff
Заглянувший



Joined: 07 Jun 2012
Posts: 5
Карма: -2
   поощрить/наказать


PostPosted: Fri Jun 08, 2012 9:58 pm (спустя 3 часа 39 минут; написано за 1 секунду)
   Post subject: IIS
Reply with quote

Нету.
Back to top
View user's profile Send private message
vlad-sheff
Заглянувший



Joined: 07 Jun 2012
Posts: 5
Карма: -2
   поощрить/наказать


PostPosted: Fri Jun 08, 2012 10:09 pm (спустя 11 минут; написано за 29 секунд)
   Post subject:
Reply with quote

Извините, не увидел што он у меня включен.
Спасибо)
Back to top
View user's profile Send private message
vlad-sheff
Заглянувший



Joined: 07 Jun 2012
Posts: 5
Карма: -2
   поощрить/наказать


PostPosted: Fri Jun 08, 2012 10:15 pm (спустя 6 минут; написано за 51 секунду)
   Post subject:
Reply with quote

Но теперь если запустить перишко в треє, то вискакивает:
disabled use of AcceptEx<> WinSock2 API ------ето так должно бить?
localhost грузитса.
Back to top
View user's profile Send private message
Maus
Модератор



Joined: 29 Jun 2003
Posts: 8151
Карма: 271
   поощрить/наказать

Location: пос. Омсукчан Магаданской области

PostPosted: Tue Jun 12, 2012 12:20 am (спустя 3 дня 2 часа 5 минут; написано за 2 секунды)
   Post subject:
Reply with quote

vlad-sheff wrote:
так должно бить?
Да
Back to top
View user's profile Send private message
vlad-sheff
Заглянувший



Joined: 07 Jun 2012
Posts: 5
Карма: -2
   поощрить/наказать


PostPosted: Wed Jun 13, 2012 12:58 am (спустя 1 день 37 минут; написано за 6 секунд)
   Post subject:
Reply with quote

Спасибо за ответи.
Back to top
View user's profile Send private message
Maverrik
Заглянувший



Joined: 18 Jun 2012
Posts: 4
Карма: -2
   поощрить/наказать


PostPosted: Mon Jun 18, 2012 11:30 pm (спустя 5 дней 22 часа 31 минуту; написано за 4 минуты 4 секунды)
   Post subject:
Reply with quote

Здраствуйте! Я в этом деле новичок... Установил Denver, запустил, работает... Пытаюсь зайти на localhost пишет "Не удалось подключиться к удалённому серверу"... Процессы чистил, у скайпа найстроки поменял... не работает.
Пробовал telnet localhost 80 - пишет "Не удалось открыть подключение к этому узлу, на порт 80: Сбой подключения"
Я так понял, скорее всего порт 80 занят... Подскажите как решить эту проблему...
Back to top
View user's profile Send private message
Maverrik
Заглянувший



Joined: 18 Jun 2012
Posts: 4
Карма: -2
   поощрить/наказать


PostPosted: Mon Jun 18, 2012 11:32 pm (спустя 2 минуты; написано за 25 секунд)
   Post subject:
Reply with quote

В скайпе галочку убрал, процессы почистил
Back to top
View user's profile Send private message
Maus
Модератор



Joined: 29 Jun 2003
Posts: 8151
Карма: 271
   поощрить/наказать

Location: пос. Омсукчан Магаданской области

PostPosted: Tue Jun 19, 2012 12:12 am (спустя 40 минут; написано за 25 секунд)
   Post subject:
Reply with quote

Maverrik
Стандартная диагностика (forum.dklab.ru/viewtopic.php?t=20602)
Back to top
View user's profile Send private message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9989
   поощрить/наказать


PostPosted: Mon Jun 25, 2012 1:36 pm (спустя 6 дней 13 часов 23 минуты)
   Post subject:
Reply with quote


М

Ветка выделена в отдельную тему «Small HTTP Server»,
расположенную в форуме Денвер — первые шаги :: Денвер (25 Июня 2012, 14:35).
Back to top
View user's profile Send private message
NeonFrost
Заглянувший



Joined: 29 Jun 2012
Posts: 1
Карма: -1
   поощрить/наказать


PostPosted: Fri Jun 29, 2012 5:59 am (спустя 3 дня 16 часов 23 минуты; написано за 3 минуты 29 секунд)
   Post subject:
Reply with quote

Здравствуйте!
Работал с денвером около месяца, потом был перерыв в полгода. Раньше денвер работал, а сейчас не запускается апач.Перо в трее почти сразу исчезает.
ОС- Windows XP SP3
Вот файлы лога
[Fri Jun 29 12:44:06 2012] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Fri Jun 29 12:44:07 2012] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Fri Jun 29 12:44:08 2012] [notice] Apache/2.2.22 (Win32) mod_ssl/2.2.22 OpenSSL/1.0.1c PHP/5.3.13 configured -- resuming normal operations
[Fri Jun 29 12:44:08 2012] [notice] Server built: Apr 20 2012 18:42:30
[Fri Jun 29 12:44:08 2012] [error] (OS 2)Не удается найти указанный файл. : Parent: Could not set child process stdout
[Fri Jun 29 12:44:08 2012] [notice] Disabled use of AcceptEx() WinSock2 API
[Fri Jun 29 12:44:08 2012] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Fri Jun 29 12:44:09 2012] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Fri Jun 29 12:44:09 2012] [notice] Child 2280: Child process is running
[Fri Jun 29 12:44:09 2012] [crit] (OS 109)Канал был закрыт. : Child 2280: Unable to retrieve the ready event from the parent

Вроде порты 80 и 443 свободны, брандмауэр выключен, антивирусник тоже.
Подскажите, пожалуйста, в чем дело, что это за ошибка такая?
Back to top
View user's profile Send private message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9989
   поощрить/наказать


PostPosted: Fri Jun 29, 2012 7:13 am (спустя 1 час 14 минут; написано за 15 секунд)
   Post subject:
Reply with quote

NeonFrost: forum.dklab.ru/viewtopic.php?t=41752
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic All times are GMT + 3 Hours
Goto page Previous  1, 2, 3 ... 14, 15, 16, 17, 18  Next
Page 15 of 18    Email to a Friend.
You cannot post new topics in this forum. You cannot reply to topics in this forum. You cannot edit your posts in this forum. You cannot delete your posts in this forum. You cannot vote in polls in this forum. You cannot attach files in this forum. You can download files in this forum.
XML