Форум dkLab и Denwer
Здесь общаются Web-разработчики.
Генеральный спонсор:
Хостинг «Джино»

выключается httpd.exe (Roma)
Goto page Previous  1, 2
Author Message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9984
   поощрить/наказать


PostPosted: Mon Oct 26, 2009 12:19 am ()
   Post subject:
Reply with quote


М

Ветка выделена в отдельную тему «опять make_sock…»,
расположенную в форуме Лень сходить в Поиск или почитать документацию (26 Октября 2009, 01:19).
Back to top
View user's profile Send private message
lexsys7
Guest





Карма: 388
   поощрить/наказать


PostPosted: Fri Dec 04, 2009 2:13 pm (спустя 1 месяц 9 дней 13 часов 54 минуты; написано за 7 минут 36 секунд)
   Post subject: Есть ли вирусы для денвера
Reply with quote

добрый день, у меня странная проблема с денвером, пока подозрение на вирус однако антивирусник ничего не обнаруживает(avira). Суть проблемы в следующем, Денвер долгое время работал исправно, но не давно локальные сайты перестали запускаться, лезут в нет, при автономном режиме вообще не работают, при этом сам дэнвер показывает, что все впорядке и работает. Бывает с пятой-десятой попытки сайт запускается, работает какое то время, от 2 до 10 минут, а потом снова та же проблема.Переносил свои сайты на машины с рабочим денвером, там начинались те же проблемы, причем с другими сайтами тоже. Пробовал переустанавливать сервер, не помогает. В итоге, у меня в сети 4 компьютера, и все заболели одной бедой... Может, кто нибудь сталкивался с подобной проблемой...Подскажите пожалуйста
Back to top
дема
Guest





Карма: 388
   поощрить/наказать


PostPosted: Thu Dec 10, 2009 11:30 pm (спустя 6 дней 9 часов 16 минут; написано за 12 секунд)
   Post subject:
Reply with quote

похожая беда с lexsys7
помогите (((
Back to top
Vesb
Guest





Карма: 388
   поощрить/наказать


PostPosted: Sat Dec 12, 2009 12:31 am (спустя 1 день 1 час 33 секунды; написано за 1 минуту 6 секунд)
   Post subject:
Reply with quote

Если запустить Z:/usr/local/apache/bin/httpd.exe тогда открывается localhost если отключить то не открывается. Скайп, антивирусы отключил. Все равно не помогает. Windows 7 в чем может быть еще причина. Как сделать чтобы Z:/usr/local/apache/bin/httpd.exe запускался сам?
Back to top
vesb
Guest





Карма: 388
   поощрить/наказать


PostPosted: Sat Dec 12, 2009 12:42 am (спустя 11 минут; написано за 14 секунд)
   Post subject:
Reply with quote

При нажатии на коверт в системном трее. появляется такое окно
Back to top
Sadist
Заглянувший
Warnings: 1


Joined: 06 Jan 2010
Posts: 3
Карма: 0
   поощрить/наказать


PostPosted: Thu Jan 07, 2010 1:34 pm (спустя 26 дней 12 часов 52 минуты; написано за 1 минуту)
   Post subject:
Reply with quote

а у меня работало ну в начале не работало потом перезагрузил заработало но на утроопять заглючило
Back to top
View user's profile Send private message Send e-mail
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9984
   поощрить/наказать


PostPosted: Thu Jan 07, 2010 2:42 pm (спустя 1 час 7 минут; написано за 1 минуту 1 секунду)
   Post subject:
Reply with quote


!

Sadist wrote:
а у меня работало ну в начале не работало потом перезагрузил заработало но на утроопять заглючило
Sadist, хотите в бан за бессмысленный флуд?
Получаете предупреждение.
Back to top
View user's profile Send private message
linex
Guest





Карма: 388
   поощрить/наказать


PostPosted: Sat Feb 20, 2010 12:37 pm (спустя 1 месяц 12 дней 21 час 54 минуты; написано за 28 секунд)
   Post subject:
Reply with quote

У меня тоже была такая проблема. Все заработало после выхода из скайпа
Back to top
Guest






Карма: 388
   поощрить/наказать


PostPosted: Tue Jul 06, 2010 10:25 pm (спустя 4 месяца 14 дней 9 часов 47 минут; написано за 5 минут 13 секунд)
   Post subject:
Reply with quote

shaittabych.ru wrote:
Если в диспетчере задач запущен inetinfo.exe и после закрытия запускается снова, идём в управление компьютером далее службы далее IIS Admin отлючаем её и всё ок (блин, 3 часа про<censored>)
Спасибо большое за подсказку! После убийства (выключения) службы действительно всё заработало и httpd.exe уже не вылетает.
Back to top
chii
Заглянувший



Joined: 20 Jul 2010
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Tue Jul 20, 2010 6:19 pm (спустя 13 дней 19 часов 54 минуты; написано за 2 минуты 28 секунд)
   Post subject:
Reply with quote

отключается httpd
скайпа нет, iis нет, в netstat порта 127.0.0.1:80 в списке нет.
антивирус и брандмауэр отключала.
чем занят 80 порт - не понимаю.
помогите пожалуйста!
Back to top
View user's profile Send private message
Maus
Модератор



Joined: 29 Jun 2003
Posts: 8151
Карма: 271
   поощрить/наказать

Location: пос. Омсукчан Магаданской области

PostPosted: Wed Jul 21, 2010 12:16 am (спустя 5 часов 56 минут; написано за 31 секунду)
   Post subject:
Reply with quote

chii wrote:
чем занят 80 порт - не понимаю.
так может, он и не занят? Откуда такая уверенность, что дело в нем?
Back to top
View user's profile Send private message
DIMIN
Заглянувший



Joined: 21 Aug 2010
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Sat Aug 21, 2010 12:25 pm (спустя 1 месяц 12 часов 9 минут; написано за 1 минуту 25 секунд)
   Post subject:
Reply with quote

babylon_5 wrote:
Предыдущее сообщение мое. Не дописал.
Нашел решение на форуме wampserver'a.
Посмотрите 80-й порт. В частности если запущен Skype - снимите в конфигурации галочку "использовать порты 80 и 443 как альтернативные". Мне помоглось. Причем 2-й Денвер не обращает на это никакого внимания. Работает как танк. А вот 3-му не нравится.
была точно такая же проблема, сделал как вы сказали (про скайп) помогло, спасибо!
Back to top
View user's profile Send private message
ollitakich
Заглянувший



Joined: 21 Jan 2011
Posts: 2
Карма: -1
   поощрить/наказать


PostPosted: Fri Jan 21, 2011 11:27 pm (спустя 5 месяцев 11 часов 1 минуту; написано за 6 минут 58 секунд)
   Post subject:
Reply with quote

Сам столкнулся с подобной проблемой.
Выключался httpd.exe. Денвер стоял на внешнем жестком диске, и я его подключал к компу на работе.
После этого на ноутбуке выключался httpd.exe.
Проблема была в доступе к папкам, на папке с денвером стоял атрибут "только для чтения", так же локальный админ не был владельцем паки с денвером.
Что бы стать владельцем папки, необходио перейти в свойства папки -> вкладка Безопасность -> Дополнительно -> Владелец. Выбрать "Администратор" и поставить галочку на чекбоксе "Заменить владельца субконтейнеров и объектов".

Апач в логах выдавал

[Fri Jan 21 23:08:12 2011] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
[Fri Jan 21 23:08:13 2011] [warn] Init: SSL server IP/port conflict: test1.ru:443 (J:/usr/local/apache/conf/vhosts.conf:131) vs. Tools.localhost:443 (J:/usr/local/apache/conf/vhosts.conf:154)
Back to top
View user's profile Send private message
Maus
Модератор



Joined: 29 Jun 2003
Posts: 8151
Карма: 271
   поощрить/наказать

Location: пос. Омсукчан Магаданской области

PostPosted: Mon Jan 24, 2011 8:59 am (спустя 2 дня 9 часов 32 минуты; написано за 51 секунду)
   Post subject:
Reply with quote

ollitakich
и дальше выдавать будет. Посмотрите [апачевскую] документацию по SSL
Back to top
View user's profile Send private message
ollitakich
Заглянувший



Joined: 21 Jan 2011
Posts: 2
Карма: -1
   поощрить/наказать


PostPosted: Mon Jan 24, 2011 10:14 pm (спустя 13 часов 14 минут; написано за 2 минуты 22 секунды)
   Post subject:
Reply with quote

Maus
Да, вы правы, выдает то же предупреждение, но при этом апач не валится, и сайты открываются. Чем мне грозит это предупреждение?

p.s. лог апача, теперь выглядит так:

[Mon Jan 24 22:08:01 2011] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
[Mon Jan 24 22:08:01 2011] [notice] Child 3964: Child process is running
[Mon Jan 24 22:08:01 2011] [notice] Child 3964: Acquired the start mutex.
[Mon Jan 24 22:08:01 2011] [notice] Child 3964: Starting 25 worker threads.
[Mon Jan 24 22:08:02 2011] [notice] Child 3964: Listening on port 443.
[Mon Jan 24 22:08:02 2011] [notice] Child 3964: Listening on port 8648.
[Mon Jan 24 22:08:02 2011] [notice] Child 3964: Listening on port 443.
[Mon Jan 24 22:08:02 2011] [notice] Child 3964: Listening on port 80.
[Mon Jan 24 22:08:28 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Mon Jan 24 22:08:28 2011] [notice] Child 3964: Exit event signaled. Child process is ending.
[Mon Jan 24 22:08:29 2011] [notice] Child 3964: Released the start mutex
[Mon Jan 24 22:08:29 2011] [notice] Child 3964: Waiting for 25 worker threads to exit.
[Mon Jan 24 22:08:29 2011] [notice] Child 3964: All worker threads have exited.
[Mon Jan 24 22:08:29 2011] [notice] Child 3964: Child process is exiting
[Mon Jan 24 22:08:29 2011] [notice] Parent: Child process exited successfully.
Back to top
View user's profile Send private message
Maus
Модератор



Joined: 29 Jun 2003
Posts: 8151
Карма: 271
   поощрить/наказать

Location: пос. Омсукчан Магаданской области

PostPosted: Tue Jan 25, 2011 4:35 pm (спустя 18 часов 20 минут; написано за 1 минуту 20 секунд)
   Post subject:
Reply with quote

ollitakich
Ничем. Но Вы не сможете сделать 2 сертификата, которые браузер примет без ругани "в сертификате одно, а на деле другое". 1 IP == 1 сертификат
Back to top
View user's profile Send private message
Lastrel
Заглянувший



Joined: 31 May 2011
Posts: 3
Карма: -1
   поощрить/наказать


PostPosted: Sun Jun 05, 2011 2:00 am (спустя 4 месяца 10 дней 9 часов 25 минут; написано за 2 минуты 54 секунды)
   Post subject:
Reply with quote

Пробовал ставить Denwer3_Base_2008 и Denwer3_Base_2010-11-07_a2.2.4_p5.3.1_m5.1.40_pma3.2.3, через 10-15 секунд перо из трея пропадает, вручную апач тоже не запускается.
error.log выглядит так:

[Tue May 31 20:30:18 2011] [warn] Init: SSL server IP/port conflict: test1.ru:443 (X:/usr/local/apache/conf/vhosts.conf:131) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Tue May 31 20:30:18 2011] [warn] Init: SSL server IP/port conflict: subdomain.test1.ru:443 (X:/usr/local/apache/conf/vhosts.conf:108) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Tue May 31 20:30:18 2011] [warn] Init: SSL server IP/port conflict: subdomain.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:85) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Tue May 31 20:30:18 2011] [warn] Init: SSL server IP/port conflict: localhost:443 (X:/usr/local/apache/conf/vhosts.conf:39) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Tue May 31 20:30:18 2011] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
[Tue May 31 20:30:19 2011] [warn] Init: SSL server IP/port conflict: test1.ru:443 (X:/usr/local/apache/conf/vhosts.conf:131) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Tue May 31 20:30:19 2011] [warn] Init: SSL server IP/port conflict: subdomain.test1.ru:443 (X:/usr/local/apache/conf/vhosts.conf:108) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Tue May 31 20:30:19 2011] [warn] Init: SSL server IP/port conflict: subdomain.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:85) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Tue May 31 20:30:19 2011] [warn] Init: SSL server IP/port conflict: localhost:443 (X:/usr/local/apache/conf/vhosts.conf:39) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Tue May 31 20:30:19 2011] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
[Tue May 31 20:30:19 2011] [notice] Apache/2.2.4 (Win32) mod_ssl/2.2.4 OpenSSL/0.9.8k PHP/5.3.3 configured -- resuming normal operations
[Tue May 31 20:30:19 2011] [notice] Server built: Jan 9 2007 23:17:20
[Tue May 31 20:30:19 2011] [crit] (OS 4390)Этот файл или папка не являются точкой повторной обработки. : Parent: Unable to connect child stdout to NUL.
[Tue May 31 20:30:19 2011] [crit] (OS 4390)Этот файл или папка не являются точкой повторной обработки. : master_main: create child process failed. Exiting.
[Tue May 31 20:30:19 2011] [notice] Parent: Forcing termination of child process 36

Скайпом не пользуюсь. Антивирус удалял. Дополнительных фаерволов нет.
Переустанавливать ОС (win XP SP3) нежелательно (кому-то помогло).
Что ещё можно сделать?
Back to top
View user's profile Send private message
gipnozman
Заглянувший



Joined: 10 Jul 2011
Posts: 1
Карма: -1
   поощрить/наказать


PostPosted: Sun Jul 10, 2011 10:38 am (спустя 1 месяц 5 дней 8 часов 38 минут; написано за 5 минут 44 секунды)
   Post subject:
Reply with quote

Вин 7, денвер работал, вродебы, после установки какойто игрухи HTTP.EXE -W стал вылетатьчерез 25 сек после загрузки денвера, удалил все игрухи, результат не изменился, вот картинка,
Народ, я не владею навыками поиска занятости порта 80 подскажите как узнать, или дайте ссылку на тему которая уже есть, а то тут все умные и я не не совсем поймучто делают

Антивир Аваст, фаербол встроеный, денвер отлично работал еще 3 дня назаД. Немогу найти что теперь мешает.


apache.jpg
 Description:
Вылет
 Filesize:  73.34 KB
 Viewed:  35530 Time(s)

apache.jpg


Back to top
View user's profile Send private message
Александр Михалицын
Модератор



Joined: 23 May 2008
Posts: 1299
Карма: 83
   поощрить/наказать


PostPosted: Sun Jul 10, 2011 12:54 pm (спустя 2 часа 16 минут; написано за 22 секунды)
   Post subject:
Reply with quote

gipnozman,
forum.dklab.ru/viewtopic.php?t=20602

Last edited by Александр Михалицын on Sun Jul 10, 2011 2:28 pm; edited 1 time in total
Back to top
View user's profile Send private message Send e-mail
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9984
   поощрить/наказать


PostPosted: Sun Jul 10, 2011 2:25 pm (спустя 1 час 30 минут; написано за 24 секунды)
   Post subject:
Reply with quote


!

gipnozman wrote:
Народ, я не владею навыками поиска занятости порта 80 подскажите как узнать, или дайте ссылку на тему которая уже есть, а то тут все умные и я не не совсем поймучто делают
— этот форум — для профессионалов, о чём в левом верхнем углу и написано: «Здесь общаются Web-разработчики».
И от посетителей форума предполагается наличие определённых знаний и навыков.

Кроме того: Сходите, пожалуйста, в Поиск по запросу «make_sock could not bind to address». Спасибо!
Back to top
View user's profile Send private message
Lastrel
Заглянувший



Joined: 31 May 2011
Posts: 3
Карма: -1
   поощрить/наказать


PostPosted: Sat Jul 16, 2011 5:29 pm (спустя 6 дней 3 часа 3 минуты; написано за 1 минуту 2 секунды)
   Post subject:
Reply with quote

А у Web-разработчиков есть информация, на какие НЕ-лицензионные версии windows можно ставить дэнвер?
Back to top
View user's profile Send private message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9984
   поощрить/наказать


PostPosted: Sun Jul 17, 2011 1:03 am (спустя 7 часов 34 минуты; написано за 15 секунд)
   Post subject:
Reply with quote


!

Lastrel, forum.dklab.ru/about/todo/PravilaEtogoForuma-ProchitayteObyazatelno.html
Quote:
На форуме запрещается:

   …
   …
   7. обсуждение вопросов взлома, кражи контента и пиратского ПО.
Back to top
View user's profile Send private message
refer1
Заглянувший



Joined: 20 Jan 2012
Posts: 2
Карма: 0
   поощрить/наказать


PostPosted: Fri Jan 20, 2012 7:56 am (спустя 6 месяцев 3 дня 6 часов 53 минуты; написано за 16 секунд)
   Post subject: 30 секунд и вылетает
Reply with quote

[img]imagesbase.com/upload/friend_link?i=__l2_dvdrip___56__1_171_1327_35225_cjlnpqz145.jpg[/img]
Подскажите в чем причина?
303 строчка вот LoadModule php4_module "usr/local/php/sapi/php4apache.dll"
меня на "C:\Мои Web Сайты\WebServers\usr\local\php\sapiphp4apache.dll" не помогло
Back to top
View user's profile Send private message
refer1
Заглянувший



Joined: 20 Jan 2012
Posts: 2
Карма: 0
   поощрить/наказать


PostPosted: Fri Jan 20, 2012 8:07 am (спустя 11 минут; написано за 4 секунды)
   Post subject:
Reply with quote


Подскажите в чем причина?
303 строчка вот LoadModule php4_module "usr/local/php/sapi/php4apache.dll"
меня на "C:\Мои Web Сайты\WebServers\usr\local\php\sapiphp4apache.dll" не помогло
Back to top
View user's profile Send private message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9984
   поощрить/наказать


PostPosted: Fri Jan 20, 2012 1:13 pm (спустя 5 часов 5 минут; написано за 15 секунд)
   Post subject:
Reply with quote

refer1, какая у Вас версия Денвера?
Back to top
View user's profile Send private message
Maus
Модератор



Joined: 29 Jun 2003
Posts: 8151
Карма: 271
   поощрить/наказать

Location: пос. Омсукчан Магаданской области

PostPosted: Wed Feb 15, 2012 1:20 am (спустя 25 дней 12 часов 6 минут; написано за 1 минуту 6 секунд)
   Post subject:
Reply with quote

Вот тут (narod.ru/disk/23919681001/denwer3_upd_apache_php_firebird.zip.html) пока еще лежит архив с более свежими (но уже устаревшими) кусочками Денвера
Back to top
View user's profile Send private message
sadh
Заглянувший



Joined: 13 Dec 2012
Posts: 2
Карма: 0
   поощрить/наказать


PostPosted: Thu Dec 13, 2012 8:25 am (спустя 9 месяцев 27 дней 7 часов 5 минут; написано за 10 секунд)
   Post subject:
Reply with quote

Здравствуйте.

Если кому-то поможет, то буду очень рад. У меня httpd вылетал и как следствие не грузились localhost и test1.ru из-за запущенной службы VMware Workstation Server (VMwareHostd), прошу занести описание конфликта с ней в FAQ по Denwer.
Back to top
View user's profile Send private message
jony_25gr
Заглянувший



Joined: 21 Dec 2014
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Sun Dec 21, 2014 7:24 pm (спустя 2 года 8 дней 10 часов 59 минут; написано за 3 минуты 42 секунды)
   Post subject: Re: отключается httpd.exe
Reply with quote

помогите пожалуйста wrote:
помогите плиз поставил denver3 и началось, вылетает httpd.exe с таким сообщением, стоял denver2 работал нормально
РЕШЕНИЕ:
Столкнулся с этой проблемой, и о чудо нужно вырубить скайп , скайп по умолчанию занимает 80 порт вырубил скайп и вуаля все работает!
Back to top
View user's profile Send private message
Bulawka
Заглянувший



Joined: 26 Jul 2004
Posts: 3
Карма: 0
   поощрить/наказать

Location: Saint-Petersburg, Russia

PostPosted: Sat Jan 10, 2015 11:41 pm (спустя 20 дней 4 часа 16 минут; написано за 7 минут 17 секунд)
   Post subject: Re: отключается httpd.exe
Reply with quote

jony_25gr wrote:
Столкнулся с этой проблемой, и о чудо нужно вырубить скайп , скайп по умолчанию занимает 80 порт вырубил скайп и вуаля все работает!
+1, после вырубания скайпа всё поехало (при этом чекбоксик про 80 и 443 порт был снят, как и написано),
ну то есть перестал вылетать httpd.exe.
При этом на другом компе с ЭТОЙ же денверо-флешки -- всё работало и при скайпе.

Upd: если запустить Denwer (при выключенном скайпе), а потом запустить скайп -- то в этом случае они вполне мирно сосуществуют.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic All times are GMT + 3 Hours
Goto page Previous  1, 2
Page 2 of 2    Email to a Friend.
You cannot post new topics in this forum. You cannot reply to topics in this forum. You cannot edit your posts in this forum. You cannot delete your posts in this forum. You cannot vote in polls in this forum. You cannot attach files in this forum. You can download files in this forum.
XML