Форум dkLab и Denwer
Здесь общаются Web-разработчики.
Генеральный спонсор:
Хостинг «Джино»

не запускается МуPhpAdmin (Новичёк)
Goto page Previous  1, 2
Author Message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9984
   поощрить/наказать


PostPosted: Sat Feb 19, 2011 12:22 pm (написано за 8 секунд)
   Post subject:
Reply with quote

Валентинка, Сходите, пожалуйста, в Поиск по запросу «Стандартная диагностика». Спасибо!
Back to top
View user's profile Send private message
aklika
Заглянувший



Joined: 25 Feb 2011
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Fri Feb 25, 2011 10:29 pm (спустя 6 дней 10 часов 6 минут; написано за 5 минут 3 секунды)
   Post subject:
Reply with quote

При запуске localhost/Tools/phpMyAdmin вылазиет ошибка

Error

MySQL said:
#2054 - Connecting to 3.22, 3.23 & 4.0 servers is not supported
Connection for controluser as defined in your configuration failed.
phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

Перелапатила ваш форум, а проблему решить не смогла.
Несколько раз устанавливала Денвер, и с php5.3 и с php5.2 в разные директории, выдает всё-равно одно и тоже.
Что делаю не так не понимаю......
Back to top
View user's profile Send private message
Валентинка
Заглянувший



Joined: 19 Feb 2011
Posts: 2
Карма: 0
   поощрить/наказать

Location: Уфа

PostPosted: Fri Feb 25, 2011 10:30 pm (спустя 1 минуту 54 секунды; написано за 22 секунды)
   Post subject:
Reply with quote

bæv wrote:
Валентинка, Сходите, пожалуйста, в Поиск по запросу «Стандартная диагностика». Спасибо!
Спасибо, все ОК
Back to top
View user's profile Send private message
B0m.FLy
Заглянувший



Joined: 08 Jul 2011
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Fri Jul 08, 2011 11:39 am (спустя 4 месяца 10 дней 13 часов 9 минут; написано за 1 минуту 50 секунд)
   Post subject:
Reply with quote

проблему решил простым обновлением php.

1. скачайте последнюю версию здесь windows.php.net/downloads/releases/ (на данный момент это windows.php.net/downloads/releases/php-5.3.6-Win32-VC9-x86.zip)
2. в папке \WebServers\usr\local\php5\ замените файлы новыми из скачанного архива.
3. запустите денвер.
Back to top
View user's profile Send private message
AlexCar
Заглянувший



Joined: 06 Dec 2011
Posts: 4
Карма: 0
   поощрить/наказать


PostPosted: Tue Dec 06, 2011 8:23 pm (спустя 4 месяца 29 дней 8 часов 43 минуты; написано за 1 минуту 1 секунду)
   Post subject:
Reply with quote

ДОбрый день у меня вот что!!!

Welcome to phpMyAdmin

Error
MySQL said:

Cannot connect: invalid settings.

phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

 в конфиге прописано:
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root'; // MySQL user
$cfg['Servers'][$i]['password'] = 'root'; // MySQL password (only needed
$cfg['Servers'][$i]['AllowNoPassword'] = true;

Подскажите, что не так?
Back to top
View user's profile Send private message
AlexCar
Заглянувший



Joined: 06 Dec 2011
Posts: 4
Карма: 0
   поощрить/наказать


PostPosted: Tue Dec 06, 2011 8:37 pm (спустя 13 минут; написано за 1 минуту 27 секунд)
   Post subject:
Reply with quote

В общем все выше описанные способы с переустановкой более ранних или поздних версий PHP не помогают... А можно как-нибудь без PHP бэкап сдалать для переноса с локала на хостинг?
Back to top
View user's profile Send private message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9984
   поощрить/наказать


PostPosted: Wed Dec 07, 2011 3:47 am (спустя 7 часов 10 минут; написано за 1 минуту 22 секунды)
   Post subject:
Reply with quote

AlexCar wrote:
$cfg['Servers'][$i]['password'] = 'root'; // MySQL password (only needed
$cfg['Servers'][$i]['AllowNoPassword'] = true;

Подскажите, что не так?
— в Денвере по умолчанию пароль — пустой. И в денверовском phpMyAdmin'е, соответственно — тоже.
Back to top
View user's profile Send private message
AlexCar
Заглянувший



Joined: 06 Dec 2011
Posts: 4
Карма: 0
   поощрить/наказать


PostPosted: Wed Dec 07, 2011 5:00 am (спустя 1 час 12 минут; написано за 3 минуты 25 секунд)
   Post subject:
Reply with quote

bæv
Пытался и с пустым паролем входить. то же самое!!!
Welcome to phpMyAdmin

Error
MySQL said:

Cannot connect: invalid settings.

phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

 
Все же: можно ли без запуска PHPMyAdmin сделать дамп для "заливки" на хостинг? 2.5 месяца разрабатывал сайт. В локале все работает. А я не могу его "переправить".
Back to top
View user's profile Send private message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9984
   поощрить/наказать


PostPosted: Wed Dec 07, 2011 5:30 am (спустя 29 минут; написано за 5 минут 5 секунд)
   Post subject:
Reply with quote

AlexCar wrote:
Пытался и с пустым паролем входить. то же самое!!!
— либо у Вас на компьютере помимо денверовского mysql-сервера запущен сторонний (соответственно — с другими настройками).
Либо изменились логин/пароль у денверовского сервера БД.

Пробуйте сбросить root-пароль.

AlexCar wrote:
 можно ли без запуска PHPMyAdmin сделать дамп для "заливки" на хостинг?
— конечно, можно. Пользуйтесь поиском по форуму: вопрос неоднократно задавался.
Back to top
View user's profile Send private message
AlexCar
Заглянувший



Joined: 06 Dec 2011
Posts: 4
Карма: 0
   поощрить/наказать


PostPosted: Wed Dec 07, 2011 4:43 pm (спустя 11 часов 13 минут; написано за 2 минуты 53 секунды)
   Post subject:
Reply with quote

Помогла переустановка Денвера 3 - скачал улучшенную версию с PHP 5.2 - сразу без всяких проблэм запустился PHPMyAdmin. Я боялся, что при переустановке пострадает контент. Все работает. Но только в локале. На хостинге - отображается какая-то фигня. Но это другая тема уже..
Back to top
View user's profile Send private message
DonFrolenkone
Заглянувший



Joined: 10 Jan 2012
Posts: 2
Карма: -1
   поощрить/наказать


PostPosted: Tue Jan 10, 2012 9:46 pm (спустя 1 месяц 3 дня 5 часов 3 минуты; написано за 8 минут 31 секунду)
   Post subject:
Reply with quote

likemusic

полностью поддерживаю предыдущего оратора.
Закономерности подмечены верно.
Всё совпадает один в один.
К создателям Денвера- естественно претензий нет, просто хочется разобраться, что за проблемы настройки ОС-и... а вот постоянные цитаты baev-a - что у него всё работает класно уже поднадоели..

Задавался вопрос по пингу localhost
вот что выдает если пинговать с включённой локалкой и инетом:
ответ от ::1: время<1мс

если пинговать с отключённой локалкой - пинги идут нормальные:
ответ от 127.0.0.1: число байт=32 время<1мс TTL=128

естественно при подключенной локалке не работает вообще localhost.
Ферволов не стоит, антивирусник NOD5, но я думаю здесь это роли не играет...
DNS-клиент запущен...

с предыдущими версиями не тестил- хочется разобраться с этой
Back to top
View user's profile Send private message
DonFrolenkone
Заглянувший



Joined: 10 Jan 2012
Posts: 2
Карма: -1
   поощрить/наказать


PostPosted: Tue Jan 10, 2012 10:26 pm (спустя 40 минут; написано за 31 секунду)
   Post subject:
Reply with quote

DonFrolenkone wrote:
ге прописано:
c обновлённым PHP -всё заработало..
Back to top
View user's profile Send private message
mirgorod_a
Заглянувший



Joined: 15 Jan 2012
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Sun Jan 15, 2012 7:16 pm (спустя 4 дня 20 часов 49 минут; написано за 5 минут 31 секунду)
   Post subject:
Reply with quote

ПРОБЛЕМУ РЕШИЛ!

Исходные данные:
- Джентльменский Набор Web-Разработчика (PHP 5.3.3, MySQL 5.1, PostgreSQL 8.4 etc.)
- Windows 8 x64 dev version

Проблема:
- белая страница localhost/Tools/phpMyAdmin/

Решение:
- обновил PHP Version 5.3.3 на последнюю версию в момент написания поста PHP Version 5.3.9 (windows.php.net/downloads/releases/php-5.3.9-Win32-VC9-x86.zip). Распаковал архив php-5.3.9-Win32-VC9-x86.zip и скопировал содержимое данной папки в директорию Денвера3 C:\denwer\usr\local\php5\ заменив файлы по требованию.
- запустил от имени администратора C:\denwer\denwer\Run.exe

где C:\denwer\ - директория с Денвером
Back to top
View user's profile Send private message
alennnka34
Заглянувший



Joined: 19 Jan 2012
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Thu Jan 19, 2012 6:25 pm (спустя 3 дня 23 часа 8 минут; написано за 8 минут 2 секунды)
   Post subject:
Reply with quote

aklika wrote:
При запуске localhost/Tools/phpMyAdmin вылазиет ошибка
Перелапатила ваш форум, а проблему решить не смогла.
Несколько раз устанавливала Денвер, и с php5.3 и с php5.2 в разные директории, выдает всё-равно одно и тоже.
Что делаю не так не понимаю......
аналогичная проблема.
W7 x64 домашняя расширенная, апача, php, sql ранее на машине не было.
устанавливала денвер, и с 5.3 и с 5.2. качала пакеты - предложенные ниже, распаковывала и на Z и на С/WebServers, ничего не помогает.

 phpMyAdmin пишет: Error

MySQL said:
 #1045 - Access denied for user 'root'@'localhost' (using password: NO)

Заведение новых БД и пользователей MySQL: Ошибка: Access denied for user 'root'@'localhost' (using password: NO).

что делать? сбрасывать рутовский пароль?
Back to top
View user's profile Send private message
memo
Заглянувший



Joined: 05 Feb 2012
Posts: 4
Карма: 1
   поощрить/наказать


PostPosted: Mon Feb 06, 2012 5:03 pm (спустя 17 дней 22 часа 38 минут; написано за 9 минут 58 секунд)
   Post subject:
Reply with quote

alennnka34 wrote:
устанавливала денвер, и с 5.3 и с 5.2. качала пакеты - предложенные ниже, распаковывала и на Z и на С/WebServers, ничего не помогает.

 phpMyAdmin пишет: Error

MySQL said:
 #1045 - Access denied for user 'root'@'localhost' (using password: NO)
У меня была аналогичная картина. Просто забыл нажать на SwitchOff.exe при удалении версии Денвера с 5.3. А потом повторил ещё раз со SwitchOff.exe и с 5.2. - заработало.
Back to top
View user's profile Send private message
saegel
Заглянувший



Joined: 07 Feb 2012
Posts: 2
Карма: -1
   поощрить/наказать


PostPosted: Tue Feb 07, 2012 10:22 pm (спустя 1 день 5 часов 18 минут)
   Post subject:
Reply with quote

Установил на XPsp3 работает, а на новый ноут под Wind 7 админ не работает
ПОМОЖИТЕ ЧЕМ МОЖЕТЕ ;)
localhost/Tools/phpMyAdmin не запускается и выдает ошибку:
- #2003 - The server is not responding
- Connection for controluser as defined in your configuration failed
Потерял несколько дней читая форум сформировал что имею
- описанные порты 80 и 443 заняты httpd.exe
- порт 3306 занят mysqld.exe
- при создании новой БД Ошибка: Can't connect to MySQL server on 'localhost' (10061).
- Loaded Configuration File Z:\usr\local\php5\php.ini
- Client API version 5.0.51a
- PATH \usr\local\ImageMagick;\usr\local\php5;C:\Program Files\Common Files\Microsoft Shared\Windows Live;
C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\Windows\system32;C:\Windows;
C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;
c:\Program Files (x86)\Common Files\Roxio Shared\OEM\DLLShared\;
c:\Program Files (x86)\Common Files\Roxio Shared\OEM\DLLShared\;
c:\Program Files (x86)\Common Files\Roxio Shared\OEM\12.0\DLLShared\;
c:\Program Files (x86)\Roxio\OEM\AudioCore\;C:\Program Files (x86)\Windows Live\Shared;
C:\Program Files (x86)\QuickTime\QTSystem\
- ping 127.0.0.1, игорь-ПК, Эхо ответ, 0,
- общий доступ сделал С:\WebServers
!? общий доступ на диск Z не удалось- "Устройство или каталог не существует" я так понял виртуальный диск
- в антивирусе все исключения по Денверу
- access.log
127.0.0.1 - - [07/Feb/2012:17:16:43 +0400] "GET /Tools/phpMyAdmin/ HTTP/1.1" 200 2967
127.0.0.1 - - [07/Feb/2012:17:16:46 +0400] "GET /Tools/phpMyAdmin/phpmyadmin.css.php?token=b455caa073948f676e3fee1d2e5f3d5d&js_frame=right&nocache=3771113523 HTTP/1.1" 200 21389
127.0.0.1 - - [07/Feb/2012:17:16:46 +0400] "GET /Tools/phpMyAdmin/phpmyadmin.css.php?token=b455caa073948f676e3fee1d2e5f3d5d&js_frame=right&nocache=3771113523 HTTP/1.1" 200 16114
127.0.0.1 - - [07/Feb/2012:17:57:02 +0400] "GET /Tools/phpmyadmin/index.php HTTP/1.1" 200 3129
127.0.0.1 - - [07/Feb/2012:17:57:05 +0400] "GET /Tools/phpmyadmin/print.css HTTP/1.1" 200 1063
127.0.0.1 - - [07/Feb/2012:17:57:05 +0400] "GET /Tools/phpmyadmin/themes/original/img/window-new.png HTTP/1.1" 200 583
127.0.0.1 - - [07/Feb/2012:17:57:05 +0400] "GET /Tools/phpmyadmin/themes/original/img/b_help.png HTTP/1.1" 200 229
127.0.0.1 - - [07/Feb/2012:17:57:05 +0400] "GET /Tools/phpmyadmin/phpmyadmin.css.php?lang=en-utf-8&convcharset=utf-8&collation_connection=utf8_general_ci&token=73cfc897f2968969f094762637e335ab&js_frame=right&nocache=3771113523 HTTP/1.1" 200 21389
127.0.0.1 - - [07/Feb/2012:17:57:05 +0400] "GET /Tools/phpmyadmin/themes/original/img/s_warn.png HTTP/1.1" 200 261
127.0.0.1 - - [07/Feb/2012:17:57:05 +0400] "GET /Tools/phpmyadmin/themes/original/img/s_error.png HTTP/1.1" 200 272
127.0.0.1 - - [07/Feb/2012:17:57:05 +0400] "GET /Tools/phpmyadmin/favicon.ico HTTP/1.1" 200 18902
- mysql-5.1
120207 22:51:21 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The first specified data file .\ibdata1 did not exist:
InnoDB: a new database to be created!
120207 22:51:21 InnoDB: Setting file .\ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
120207 22:51:21 InnoDB: Log file .\ib_logfile0 did not exist: new to be created
InnoDB: Setting log file .\ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
120207 22:51:21 InnoDB: Log file .\ib_logfile1 did not exist: new to be created
InnoDB: Setting log file .\ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
120207 22:51:23 InnoDB: Started; log sequence number 0 0
120207 22:51:23 [Note] Event Scheduler: Loaded 0 events
120207 22:51:23 [Note] \usr\local\mysql-5.1\bin\mysqld.exe: ready for connections.
Version: '5.1.40-community' socket: '' port: 3306 MySQL Community Server (GPL)
120207 22:53:48 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
120207 22:53:48 InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
120207 22:53:48 InnoDB: Started; log sequence number 0 44233
120207 22:53:49 [Note] Event Scheduler: Loaded 0 events
120207 22:53:49 [Note] \usr\local\mysql-5.1\bin\mysqld.exe: ready for connections.
Version: '5.1.40-community' socket: '' port: 3306 MySQL Community Server (GPL)
Back to top
View user's profile Send private message
saegel
Заглянувший



Joined: 07 Feb 2012
Posts: 2
Карма: -1
   поощрить/наказать


PostPosted: Tue Feb 21, 2012 12:31 pm (спустя 13 дней 14 часов 9 минут; написано за 3 минуты 39 секунд)
   Post subject:
Reply with quote

Вообщем установил денвер на флеш без виртуального диска и все заработало.
Вероятно проблема в обращении к виртуальному диску Т.к. устанавливал на
диск Д вообще не запускалась страница
Кто в этом разобрался прошу ссылку
Back to top
View user's profile Send private message
olga_arb
Заглянувший



Joined: 07 Sep 2012
Posts: 10
Карма: 0
   поощрить/наказать


PostPosted: Wed Feb 06, 2013 8:27 am (спустя 11 месяцев 13 дней 19 часов 56 минут; написано за 9 секунд)
   Post subject:
Reply with quote

У меня myphpadmin запускается, но при создании базы, изменении привилегий выдается сообщение "Загрузка" и все, без результата? А
утилита "Заведение новых БД и пользователей MySQL" со страницы localhost работает, создает БД. В чем может быть проблема?
Back to top
View user's profile Send private message
vecnyistudent
Заглянувший



Joined: 08 May 2014
Posts: 2
Карма: 0
   поощрить/наказать


PostPosted: Fri May 09, 2014 9:56 pm (спустя 1 год 3 месяца 3 дня 13 часов 29 минут; написано за 16 секунд)
   Post subject:
Reply with quote

GuestРешить проблему удалось?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic All times are GMT + 3 Hours
Goto page Previous  1, 2
Page 2 of 2    Email to a Friend.
You cannot post new topics in this forum. You cannot reply to topics in this forum. You cannot edit your posts in this forum. You cannot delete your posts in this forum. You cannot vote in polls in this forum. You cannot attach files in this forum. You can download files in this forum.
XML